summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorINADA Naoki <inada-n@klab.com>2012-08-19 03:04:19 +0900
committerINADA Naoki <inada-n@klab.com>2012-08-19 03:04:19 +0900
commit29b4b785d0152c964819bc613a0321214df78c47 (patch)
tree0a4dff56fc296bc8d00eaa112b4bb4739b15fe53 /setup.py
parent670bb3ca154d5f86fe72fe34a73d0ca8b7bd315a (diff)
downloadmsgpack-python-29b4b785d0152c964819bc613a0321214df78c47.tar.gz
Fix build_ext doesn't work on Python 3.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 074700b..b03647a 100644
--- a/setup.py
+++ b/setup.py
@@ -49,7 +49,7 @@ Install Cython >= 0.16 or install msgpack from PyPI.
class BuildExt(build_ext):
def build_extension(self, ext):
- ext.sources = map(ensure_source, ext.sources)
+ ext.sources = list(map(ensure_source, ext.sources))
return build_ext.build_extension(self, ext)