summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorINADA Naoki <songofacandy@gmail.com>2010-09-02 09:54:38 +0900
committerINADA Naoki <songofacandy@gmail.com>2010-09-02 09:54:38 +0900
commit50ffd2c489fdab81da2d994794b9582e0cadf5f4 (patch)
tree0f0339f59895c07dc36e5435f7ea9707f2975a71 /setup.py
parent039542ebcb8ca923c4414a414ecd62df43ff3f24 (diff)
downloadmsgpack-python-50ffd2c489fdab81da2d994794b9582e0cadf5f4.tar.gz
Add msgpack.version as version tuple.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 6 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 64e71ed..c79c148 100755
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,6 @@
#!/usr/bin/env python
# coding: utf-8
+version = (0, 1, 5, 'dev')
import os
from glob import glob
@@ -14,7 +15,10 @@ except ImportError:
from distutils.command.build_ext import build_ext
have_cython = False
-version = '0.1.4'
+# make msgpack/__verison__.py
+f = open('msgpack/__version__.py', 'w')
+f.write("version = %r\n" % (version,))
+f.close()
# take care of extension modules.
if have_cython:
@@ -53,7 +57,7 @@ What's MessagePack? (from http://msgpack.sourceforge.net/)
setup(name='msgpack-python',
author='INADA Naoki',
author_email='songofacandy@gmail.com',
- version=version,
+ version=''.join(str(x) for x in version),
cmdclass={'build_ext': build_ext, 'sdist': Sdist},
ext_modules=[msgpack_mod],
packages=['msgpack'],