summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJoel Nothman <joel.nothman@gmail.com>2012-09-25 00:30:15 +1000
committerJoel Nothman <joel.nothman@gmail.com>2012-09-25 00:30:15 +1000
commitd56e2b2c8aa1005fbac3b584cd003ba0cdece2e2 (patch)
tree46610af74cb781f5a3918420b5bd4fab131bdd4a /setup.py
parent96ed236c1d53e9ac4f3632ed82f15a1d6e0604da (diff)
downloadmsgpack-python-d56e2b2c8aa1005fbac3b584cd003ba0cdece2e2.tar.gz
Use C++ function templating for skip()/construct()
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 86b0b34..708fa13 100644
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,7 @@ except ImportError:
def cythonize(src):
sys.stderr.write("cythonize: %r\n" % (src,))
- cython_compiler.compile([src])
+ cython_compiler.compile([src], cplus=True)
def ensure_source(src):
pyx = os.path.splitext(src)[0] + '.pyx'
@@ -67,7 +67,7 @@ if have_cython:
else:
Sdist = sdist
-sources = ['msgpack/_msgpack.c']
+sources = ['msgpack/_msgpack.cpp']
libraries = []
if sys.platform == 'win32':
libraries.append('ws2_32')