summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorINADA Naoki <methane@users.noreply.github.com>2018-11-14 16:35:37 +0900
committerGitHub <noreply@github.com>2018-11-14 16:35:37 +0900
commitd782464c9150e448ab3a8d81197ff335e1ac2c2b (patch)
treed008991560c7ca596e11e4e760a3e613fe252bc4 /setup.py
parent2b5f59166beeccde0ee230c8673cf50932c8daba (diff)
downloadmsgpack-python-d782464c9150e448ab3a8d81197ff335e1ac2c2b.tar.gz
Refactor Cython code (#328)
_msgpack -> _cmsgpack
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 8b8f7bd..eb9403f 100755
--- a/setup.py
+++ b/setup.py
@@ -68,7 +68,7 @@ if len(version) > 3 and version[3] != 'final':
if have_cython:
class Sdist(sdist):
def __init__(self, *args, **kwargs):
- cythonize('msgpack/_msgpack.pyx')
+ cythonize('msgpack/_cmsgpack.pyx')
sdist.__init__(self, *args, **kwargs)
else:
Sdist = sdist
@@ -84,8 +84,8 @@ else:
ext_modules = []
if not hasattr(sys, 'pypy_version_info'):
- ext_modules.append(Extension('msgpack._msgpack',
- sources=['msgpack/_msgpack.cpp'],
+ ext_modules.append(Extension('msgpack._cmsgpack',
+ sources=['msgpack/_cmsgpack.cpp'],
libraries=libraries,
include_dirs=['.'],
define_macros=macros,