summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorINADA Naoki <inada-n@klab.com>2012-10-01 01:31:58 +0900
committerINADA Naoki <inada-n@klab.com>2012-10-01 01:31:58 +0900
commite016b3dca0d8ca71fa54ffadfa1e5d9f3e4b3f06 (patch)
tree45daae42bfd00afdc27a7565f32ec061eb771bd7 /setup.py
parent1526316a0803c233a6752aff1bab6e951447d12a (diff)
parent9d9c3eecb846c6a927a31aae394dea39fa75aef4 (diff)
downloadmsgpack-python-e016b3dca0d8ca71fa54ffadfa1e5d9f3e4b3f06.tar.gz
Merge remote-tracking branch 'jnothman/read_size_cpp'
Conflicts: msgpack/_msgpack.pyx setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 2 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 9f0ce5d..5be92bf 100644
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,7 @@ except ImportError:
def cythonize(src):
sys.stderr.write("cythonize: %r\n" % (src,))
- cython_compiler.compile([src], emit_linenums=True)
+ cython_compiler.compile([src], cplus=True, emit_linenums=True)
def ensure_source(src):
pyx = os.path.splitext(src)[0] + '.pyx'
@@ -34,13 +34,6 @@ Install Cython >= 0.16 or install msgpack from PyPI.
os.stat(src).st_mtime < os.stat(pyx).st_mtime and
have_cython):
cythonize(pyx)
-
- # Use C++ compiler on win32.
- # MSVC9 doesn't provide stdint.h when using C Compiler.
- if sys.platform == 'win32':
- cpp = src + 'pp'
- shutil.copy(src, cpp)
- return cpp
else:
return src
@@ -67,7 +60,7 @@ if have_cython:
else:
Sdist = sdist
-sources = ['msgpack/_msgpack.c']
+sources = ['msgpack/_msgpack.cpp']
libraries = []
if sys.platform == 'win32':
libraries.append('ws2_32')