summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorINADA Naoki <songofacandy@gmail.com>2018-10-03 20:55:51 +0900
committerInada Naoki <songofacandy@gmail.com>2018-11-08 20:27:35 +0900
commitf6f95972492bcb83d8fe4c63be3b96d46e47bab7 (patch)
treee0003078b772d6c0e3a22862f8494bb723388a97 /setup.py
parent91ec9e1daf5cc915a47e2b356a7b1dd9662573a3 (diff)
downloadmsgpack-python-f6f95972492bcb83d8fe4c63be3b96d46e47bab7.tar.gz
Merge extension module
There were `_packer.so` and `_unpacker.so`. But single module is simpler than double module. Merge extension module into single `_msgpack.so`.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py13
1 files changed, 3 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index c252d81..8b8f7bd 100755
--- a/setup.py
+++ b/setup.py
@@ -68,8 +68,7 @@ if len(version) > 3 and version[3] != 'final':
if have_cython:
class Sdist(sdist):
def __init__(self, *args, **kwargs):
- for src in glob('msgpack/*.pyx'):
- cythonize(src)
+ cythonize('msgpack/_msgpack.pyx')
sdist.__init__(self, *args, **kwargs)
else:
Sdist = sdist
@@ -85,14 +84,8 @@ else:
ext_modules = []
if not hasattr(sys, 'pypy_version_info'):
- ext_modules.append(Extension('msgpack._packer',
- sources=['msgpack/_packer.cpp'],
- libraries=libraries,
- include_dirs=['.'],
- define_macros=macros,
- ))
- ext_modules.append(Extension('msgpack._unpacker',
- sources=['msgpack/_unpacker.cpp'],
+ ext_modules.append(Extension('msgpack._msgpack',
+ sources=['msgpack/_msgpack.cpp'],
libraries=libraries,
include_dirs=['.'],
define_macros=macros,