summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--docker/buildwheel.sh11
2 files changed, 15 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 2e53d08..6eaef53 100644
--- a/Makefile
+++ b/Makefile
@@ -20,3 +20,7 @@ python3: cython
test:
py.test test
+
+build-manylinux1-wheel:
+ docker run --rm -ti -v `pwd`:/project -w /project quay.io/pypa/manylinux1_i686 bash docker/buildwheel.sh
+ docker run --rm -ti -v `pwd`:/project -w /project quay.io/pypa/manylinux1_x86_64 bash docker/buildwheel.sh
diff --git a/docker/buildwheel.sh b/docker/buildwheel.sh
new file mode 100644
index 0000000..b654e45
--- /dev/null
+++ b/docker/buildwheel.sh
@@ -0,0 +1,11 @@
+#!/bin/bash
+set -e -x
+
+ARCH=`uname -p`
+echo "arch=$ARCH"
+
+for V in cp35-cp35m cp34-cp34m cp27-cp27m cp27-cp27mu; do
+ PYBIN=/opt/python/$V/bin
+ rm -rf build/ # Avoid lib build by narrow Python is used by wide python
+ $PYBIN/python setup.py bdist_wheel -p manylinux1_${ARCH}
+done