summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.github/workflows/windows.yaml70
-rw-r--r--ci/runtests.bat2
-rw-r--r--ci/runtests.sh8
3 files changed, 79 insertions, 1 deletions
diff --git a/.github/workflows/windows.yaml b/.github/workflows/windows.yaml
new file mode 100644
index 0000000..cecb825
--- /dev/null
+++ b/.github/workflows/windows.yaml
@@ -0,0 +1,70 @@
+name: Build and test windows wheels
+on:
+ push:
+ branches:
+ - master
+ - test
+ pull_request:
+ create:
+
+jobs:
+ build:
+ runs-on: windows-latest
+ steps:
+ - name: Checkout
+ uses: actions/checkout@v1
+
+ - name: Cythonize
+ shell: bash
+ run: |
+ pip install -U Cython
+ make cython
+ #python setup.py sdist
+
+ - name: Python 3.6 (amd64)
+ env:
+ PYTHON: "py -3.6-64"
+ shell: bash
+ run: |
+ ci/runtests.sh
+
+ - name: Python 3.6 (x86)
+ env:
+ PYTHON: "py -3.6-32"
+ shell: bash
+ run: |
+ ci/runtests.sh
+
+ - name: Python 3.7 (amd64)
+ env:
+ PYTHON: "py -3.7-64"
+ shell: bash
+ run: |
+ ci/runtests.sh
+
+ - name: Python 3.7 (x86)
+ env:
+ PYTHON: "py -3.7-32"
+ shell: bash
+ run: |
+ ci/runtests.sh
+
+ - name: Python 3.8 (amd64)
+ env:
+ PYTHON: "py -3.8-64"
+ shell: bash
+ run: |
+ ci/runtests.sh
+
+ - name: Python 3.8 (x86)
+ env:
+ PYTHON: "py -3.8-32"
+ shell: bash
+ run: |
+ ci/runtests.sh
+
+ - name: Upload Wheels
+ uses: actions/upload-artifact@v1
+ with:
+ name: win-wheels
+ path: ./dist
diff --git a/ci/runtests.bat b/ci/runtests.bat
index 0240467..4ae2f70 100644
--- a/ci/runtests.bat
+++ b/ci/runtests.bat
@@ -2,7 +2,7 @@
%PYTHON%\python.exe setup.py build_ext -i
%PYTHON%\python.exe setup.py install
%PYTHON%\python.exe -c "import sys; print(hex(sys.maxsize))"
-%PYTHON%\python.exe -c "from msgpack import _packer, _unpacker"
+%PYTHON%\python.exe -c "from msgpack import _cmsgpack"
%PYTHON%\python.exe setup.py bdist_wheel
%PYTHON%\python.exe -m pytest -v test
SET EL=%ERRORLEVEL%
diff --git a/ci/runtests.sh b/ci/runtests.sh
new file mode 100644
index 0000000..5d87f69
--- /dev/null
+++ b/ci/runtests.sh
@@ -0,0 +1,8 @@
+#!/bin/bash
+set -ex
+${PYTHON} -VV
+${PYTHON} -m pip install setuptools wheel pytest
+${PYTHON} setup.py build_ext -if
+${PYTHON} -c "from msgpack import _cmsgpack"
+${PYTHON} setup.py bdist_wheel
+${PYTHON} -m pytest -v test