summaryrefslogtreecommitdiff
path: root/docker/runtests.sh
diff options
context:
space:
mode:
Diffstat (limited to 'docker/runtests.sh')
-rwxr-xr-xdocker/runtests.sh14
1 files changed, 14 insertions, 0 deletions
diff --git a/docker/runtests.sh b/docker/runtests.sh
new file mode 100755
index 0000000..0d74802
--- /dev/null
+++ b/docker/runtests.sh
@@ -0,0 +1,14 @@
+#!/bin/bash
+set -e -x
+
+for V in cp35-cp35m cp34-cp34m cp27-cp27m cp27-cp27mu; do
+ PYBIN=/opt/python/$V/bin
+ $PYBIN/python setup.py install
+ rm -rf build/ # Avoid lib build by narrow Python is used by wide python
+ $PYBIN/pip install pytest
+ pushd test # prevent importing msgpack package in current directory.
+ $PYBIN/python -c 'import sys; print(hex(sys.maxsize))'
+ $PYBIN/python -c 'from msgpack import _packer, _unpacker'
+ $PYBIN/py.test -v
+ popd
+done