summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml7
-rw-r--r--MySQLdb/tests/test_MySQLdb_capabilities.py2
-rw-r--r--MySQLdb/tests/test_MySQLdb_dbapi20.py2
-rw-r--r--MySQLdb/tests/test_MySQLdb_nonstandard.py2
4 files changed, 10 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..d35257b
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,7 @@
+language: python
+python:
+ - "2.5"
+ - "2.6"
+ - "2.7"
+install: (cd MySQLdb && python setup.py install)
+script: (cd MySQLdb && nosetests)
diff --git a/MySQLdb/tests/test_MySQLdb_capabilities.py b/MySQLdb/tests/test_MySQLdb_capabilities.py
index a510468..c4b3a73 100644
--- a/MySQLdb/tests/test_MySQLdb_capabilities.py
+++ b/MySQLdb/tests/test_MySQLdb_capabilities.py
@@ -10,7 +10,7 @@ class test_MySQLdb(capabilities.DatabaseTest):
db_module = MySQLdb
connect_args = ()
- connect_kwargs = dict(db='test', host="127.0.0.1", user="test", #read_default_file='~/.my.cnf',
+ connect_kwargs = dict(db='test', host="127.0.0.1", user="root",
charset='utf8', sql_mode="ANSI,STRICT_TRANS_TABLES,TRADITIONAL")
create_table_extra = "ENGINE=INNODB CHARACTER SET UTF8"
leak_test = False
diff --git a/MySQLdb/tests/test_MySQLdb_dbapi20.py b/MySQLdb/tests/test_MySQLdb_dbapi20.py
index 4f4527a..a8441bd 100644
--- a/MySQLdb/tests/test_MySQLdb_dbapi20.py
+++ b/MySQLdb/tests/test_MySQLdb_dbapi20.py
@@ -8,7 +8,7 @@ class test_MySQLdb(dbapi20.DatabaseAPI20Test):
connect_args = ()
connect_kw_args = dict(db='test',
host="127.0.0.1",
- user="test", #read_default_file='~/.my.cnf',
+ user="root",
charset='utf8',
sql_mode="ANSI,STRICT_TRANS_TABLES,TRADITIONAL")
diff --git a/MySQLdb/tests/test_MySQLdb_nonstandard.py b/MySQLdb/tests/test_MySQLdb_nonstandard.py
index 150d013..b9b127e 100644
--- a/MySQLdb/tests/test_MySQLdb_nonstandard.py
+++ b/MySQLdb/tests/test_MySQLdb_nonstandard.py
@@ -44,7 +44,7 @@ class CoreAPI(unittest.TestCase):
"""Test _mysql interaction internals."""
def setUp(self):
- self.conn = _mysql.connect(db='test', host='127.0.0.1', user='test') #read_default_file="~/.my.cnf")
+ self.conn = _mysql.connect(db='test', host='127.0.0.1', user='root')
def tearDown(self):
self.conn.close()