summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth M Morton <seth.m.morton@gmail.com>2014-05-05 22:03:33 -0700
committerSeth M Morton <seth.m.morton@gmail.com>2014-05-05 22:03:33 -0700
commita15deceb7202c5642e1749b0ed875065771b618a (patch)
tree755717e4f5796fc16bb38c2f8de2fd0eafedf028
parent956572d68e75f8428554ec28714ae0ee127d5cc0 (diff)
parent380be48f3cb266970990a0e5d1194d2e1b98d0f2 (diff)
downloadnatsort-3.1.2.tar.gz
Merge branch 'release/3.1.2'3.1.2
-rw-r--r--MANIFEST.in1
-rw-r--r--README.rst6
-rw-r--r--natsort/_version.py2
-rw-r--r--setup.cfg2
-rw-r--r--setup.py4
5 files changed, 12 insertions, 3 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 06ccbf8..d7a368c 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -6,3 +6,4 @@ include natsort/__main__.py
include natsort/__init__.py
include natsort/py23compat.py
include setup.py
+include setup.cfg \ No newline at end of file
diff --git a/README.rst b/README.rst
index 8f78580..1195f83 100644
--- a/README.rst
+++ b/README.rst
@@ -334,6 +334,12 @@ Seth M. Morton
History
-------
+05-05-2014 v. 3.1.2
+'''''''''''''''''''
+
+ - Added setup.cfg to support universal wheels
+ - Added Python 3.0 and Python 3.1 as requiring the argparse module
+
03-01-2014 v. 3.1.1
'''''''''''''''''''
diff --git a/natsort/_version.py b/natsort/_version.py
index fdab7b2..511b39b 100644
--- a/natsort/_version.py
+++ b/natsort/_version.py
@@ -1,4 +1,4 @@
# -*- coding: utf-8 -*-
from __future__ import unicode_literals
-__version__ = '3.1.1'
+__version__ = '3.1.2'
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..2a9acf1
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,2 @@
+[bdist_wheel]
+universal = 1
diff --git a/setup.py b/setup.py
index 1b68410..9c078dd 100644
--- a/setup.py
+++ b/setup.py
@@ -26,8 +26,8 @@ try:
except IOError:
LONG_DESCRIPTION = DESCRIPTION
-# python2.6 needs the argparse module
-REQUIRES = 'argparse' if sys.version[:3] == '2.6' else ''
+# The argparse module was introduced in python 2.7 or python 3.2
+REQUIRES = 'argparse' if sys.version[:3] in ('2.6', '3.0', '3.1') else ''
# The setup parameters
setup(name='natsort',