summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Morton <seth.m.morton@gmail.com>2019-11-09 21:51:31 -0800
committerSeth Morton <seth.m.morton@gmail.com>2019-11-09 21:52:41 -0800
commitcf2686d85553fd7884a00d7c6f4abe803633a09e (patch)
treed02c04f2fe2b6e88f22287bb31bb8dc5a136e8da
parent1e30d4d99627d1e9a2039cdcb2d0ffd16d8e9bff (diff)
downloadnatsort-6.1.0.tar.gz
Bump version: 6.0.0 → 6.1.06.1.0
-rw-r--r--CHANGELOG.md4
-rw-r--r--docs/conf.py2
-rw-r--r--natsort/__init__.py2
-rw-r--r--setup.cfg2
-rw-r--r--setup.py2
5 files changed, 8 insertions, 4 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 81d699b..4e7e054 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,9 @@
Unreleased
---
+[6.1.0] - 2019-11-09
+---
+
### Added
- Expose `numeric_regex_chooser` as a public function for ease in making
key functions
@@ -485,6 +488,7 @@ a pipeline by which to filter
- Sorting algorithm to support floats (including exponentials) and basic version number support
<!---Comparison links-->
+[6.1.0]: https://github.com/SethMMorton/natsort/compare/6.0.0...6.1.0
[6.0.0]: https://github.com/SethMMorton/natsort/compare/5.5.0...6.0.0
[5.5.0]: https://github.com/SethMMorton/natsort/compare/5.4.1...5.5.0
[5.4.1]: https://github.com/SethMMorton/natsort/compare/5.4.0...5.4.1
diff --git a/docs/conf.py b/docs/conf.py
index cbcaab4..b746a90 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -58,7 +58,7 @@ copyright = u'2014, Seth M. Morton'
# built documents.
#
# The full version, including alpha/beta/rc tags.
-release = '6.0.0'
+release = '6.1.0'
# The short X.Y version.
version = '.'.join(release.split('.')[0:2])
diff --git a/natsort/__init__.py b/natsort/__init__.py
index 561164b..c27c7de 100644
--- a/natsort/__init__.py
+++ b/natsort/__init__.py
@@ -24,7 +24,7 @@ from natsort.utils import chain_functions
if float(sys.version[:3]) < 3:
from natsort.natsort import natcmp
-__version__ = "6.0.0"
+__version__ = "6.1.0"
__all__ = [
"natsort_key",
diff --git a/setup.cfg b/setup.cfg
index 07bcc9a..1d61786 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,5 @@
[bumpversion]
-current_version = 6.0.0
+current_version = 6.1.0
commit = True
tag = True
tag_name = {new_version}
diff --git a/setup.py b/setup.py
index 68e06fc..c732bea 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@
from setuptools import find_packages, setup
setup(
name='natsort',
- version='6.0.0',
+ version='6.1.0',
packages=find_packages(),
entry_points={'console_scripts': ['natsort = natsort.__main__:main']},
python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",