summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth M Morton <seth.m.morton@gmail.com>2018-05-17 22:55:49 -0400
committerSeth M Morton <seth.m.morton@gmail.com>2018-05-17 22:58:45 -0400
commitf030b145e04159468149e7fc18333980319c3946 (patch)
tree5e65a91a29bccadcaa838b557439d3b46502b0d8
parenta0485bd7d805137bc2730b70c7ad11d1bd80f15f (diff)
downloadnatsort-dont-be-pretentious.tar.gz
Add skip_missing_interpreters to tox.ini.dont-be-pretentious
This way users will not be penalized if they do not have all python versions installed. The docs are updated to suggest just calling tox with no arguments.
-rw-r--r--README.rst16
-rw-r--r--docs/source/intro.rst16
-rw-r--r--tox.ini4
3 files changed, 14 insertions, 22 deletions
diff --git a/README.rst b/README.rst
index 9c71a4f..783d109 100644
--- a/README.rst
+++ b/README.rst
@@ -305,22 +305,16 @@ How to Run Tests
Please note that ``natsort`` is NOT set-up to support ``python setup.py test``.
The recommended way to run tests is with `tox <https://tox.readthedocs.io/en/latest/>`_.
-Suppose you want to run tests for Python 3.6 - you can run tests by simply executing the
-following:
+After installing ``tox``, running tests is as simple as executing the following in the
+``natsort`` directory:
.. code-block:: sh
- $ tox -e py36
+ $ tox
``tox`` will create virtual a virtual environment for your tests and install all the
-needed testing requirements for you.
-
-If you want to run testing on all of Python 2.7, 3.4, 3.5, and 3.6 you can simply
-execute
-
-.. code-block:: sh
-
- $ tox
+needed testing requirements for you. You can specify a particular python version
+with the ``-e`` flag, e.g. ``tox -e py36``.
If you do not wish to use ``tox``, you can install the testing dependencies and run the
tests manually using `pytest <https://docs.pytest.org/en/latest/>`_ - ``natsort``
diff --git a/docs/source/intro.rst b/docs/source/intro.rst
index 790234b..40aaad3 100644
--- a/docs/source/intro.rst
+++ b/docs/source/intro.rst
@@ -308,22 +308,16 @@ How to Run Tests
Please note that :mod:`natsort` is NOT set-up to support ``python setup.py test``.
The recommended way to run tests is with `tox <https://tox.readthedocs.io/en/latest/>`_.
-Suppose you want to run tests for Python 3.6 - you can run tests by simply executing the
-following:
+After installing ``tox``, running tests is as simple as executing the following in the
+``natsort`` directory:
.. code-block:: sh
- $ tox -e py36
+ $ tox
``tox`` will create virtual a virtual environment for your tests and install all the
-needed testing requirements for you.
-
-If you want to run testing on all of Python 2.7, 3.4, 3.5, and 3.6 you can simply
-execute
-
-.. code-block:: sh
-
- $ tox
+needed testing requirements for you. You can specify a particular python version
+with the ``-e`` flag, e.g. ``tox -e py36``.
If you do not wish to use ``tox``, you can install the testing dependencies and run the
tests manually using `pytest <https://docs.pytest.org/en/latest/>`_ - ``natsort``
diff --git a/tox.ini b/tox.ini
index fc39d31..55ff47b 100644
--- a/tox.ini
+++ b/tox.ini
@@ -10,6 +10,10 @@ envlist =
# docs
# release
+# Don't error out if a user hasn't installed all python versions.
+skip_missing_interpreters =
+ true
+
[testenv]
passenv =
WITH_EXTRAS