summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Morton <seth.m.morton@gmail.com>2020-01-29 21:01:31 -0800
committerSeth Morton <seth.m.morton@gmail.com>2020-01-29 21:01:31 -0800
commitd37289556818f10619c4a15ca9b9d315b5a2a482 (patch)
tree0fab0101ade0f5b7742fbd502420b67049286fcf
parente238a06473d0bf411e6b779e24d98f9eb58bb713 (diff)
downloadnatsort-long-term-support.tar.gz
Bump version: 6.2.0 → 6.2.16.2.1long-term-support
-rw-r--r--CHANGELOG.md4
-rw-r--r--docs/conf.py2
-rw-r--r--natsort/__init__.py2
-rw-r--r--setup.cfg2
-rw-r--r--setup.py2
5 files changed, 8 insertions, 4 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index e942037..1a9920c 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,9 @@
Unreleased
---
+[6.2.1] - 2020-01-29
+---
+
### Fixed
- Bug where that caused incorrect sorting when using locales
that have a `"."` character as the thousands separator.
@@ -511,6 +514,7 @@ a pipeline by which to filter
- Sorting algorithm to support floats (including exponentials) and basic version number support
<!---Comparison links-->
+[6.2.1]: https://github.com/SethMMorton/natsort/compare/6.2.0...6.2.1
[6.2.0]: https://github.com/SethMMorton/natsort/compare/6.1.0...6.2.0
[6.1.0]: https://github.com/SethMMorton/natsort/compare/6.0.0...6.1.0
[6.0.0]: https://github.com/SethMMorton/natsort/compare/5.5.0...6.0.0
diff --git a/docs/conf.py b/docs/conf.py
index 31f1fed..4c3bba8 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -58,7 +58,7 @@ copyright = u'2014, Seth M. Morton'
# built documents.
#
# The full version, including alpha/beta/rc tags.
-release = '6.2.0'
+release = '6.2.1'
# The short X.Y version.
version = '.'.join(release.split('.')[0:2])
diff --git a/natsort/__init__.py b/natsort/__init__.py
index 6cb28f5..cf4a6bd 100644
--- a/natsort/__init__.py
+++ b/natsort/__init__.py
@@ -24,7 +24,7 @@ from natsort.utils import chain_functions
if float(sys.version[:3]) < 3:
from natsort.natsort import natcmp
-__version__ = "6.2.0"
+__version__ = "6.2.1"
__all__ = [
"natsort_key",
diff --git a/setup.cfg b/setup.cfg
index 686ce26..2d60169 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,5 @@
[bumpversion]
-current_version = 6.2.0
+current_version = 6.2.1
commit = True
tag = True
tag_name = {new_version}
diff --git a/setup.py b/setup.py
index 220eadc..27d8c38 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@
from setuptools import find_packages, setup
setup(
name='natsort',
- version='6.2.0',
+ version='6.2.1',
packages=find_packages(),
entry_points={'console_scripts': ['natsort = natsort.__main__:main']},
python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",