summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Morton <seth.m.morton@gmail.com>2021-12-10 21:14:27 -0800
committerSeth Morton <seth.m.morton@gmail.com>2021-12-10 21:14:27 -0800
commit37cd628a6b19594a2745095d805437e731e73330 (patch)
tree182b1ba15facb84f1ff4552a92dec4407e2e3301
parent16933694aa6dc70cea5a765bc85641bbc5592bdb (diff)
downloadnatsort-37cd628a6b19594a2745095d805437e731e73330.tar.gz
Bump version: 8.0.0 → 8.0.18.0.1
-rw-r--r--CHANGELOG.md4
-rw-r--r--docs/conf.py2
-rw-r--r--natsort/__init__.py2
-rw-r--r--setup.cfg2
-rw-r--r--setup.py2
5 files changed, 8 insertions, 4 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index df15326..b05450a 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,9 @@
Unreleased
---
+[8.0.1] - 2021-12-10
+---
+
### Fixed
- Compose unicode characters when using locale to ensure sorting is correct
@@ -582,6 +585,7 @@ a pipeline by which to filter
- Sorting algorithm to support floats (including exponentials) and basic version number support
<!---Comparison links-->
+[8.0.1]: https://github.com/SethMMorton/natsort/compare/8.0.0...8.0.1
[8.0.0]: https://github.com/SethMMorton/natsort/compare/7.2.0...8.0.0
[7.2.0]: https://github.com/SethMMorton/natsort/compare/7.1.1...7.2.0
[7.1.1]: https://github.com/SethMMorton/natsort/compare/7.1.0...7.1.1
diff --git a/docs/conf.py b/docs/conf.py
index 1399b98..d4fd83d 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -59,7 +59,7 @@ copyright = "2014, Seth M. Morton"
# built documents.
#
# The full version, including alpha/beta/rc tags.
-release = "8.0.0"
+release = "8.0.1"
# The short X.Y version.
version = ".".join(release.split(".")[0:2])
diff --git a/natsort/__init__.py b/natsort/__init__.py
index c521ff7..01397fc 100644
--- a/natsort/__init__.py
+++ b/natsort/__init__.py
@@ -23,7 +23,7 @@ from natsort.natsort import (
from natsort.ns_enum import NSType, ns
from natsort.utils import KeyType, NatsortInType, NatsortOutType, chain_functions
-__version__ = "8.0.0"
+__version__ = "8.0.1"
__all__ = [
"natsort_key",
diff --git a/setup.cfg b/setup.cfg
index c7a1ac6..f0dbd59 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,5 @@
[bumpversion]
-current_version = 8.0.0
+current_version = 8.0.1
commit = True
tag = True
tag_name = {new_version}
diff --git a/setup.py b/setup.py
index 25e7aad..bb68e9a 100644
--- a/setup.py
+++ b/setup.py
@@ -4,7 +4,7 @@ from setuptools import find_packages, setup
setup(
name="natsort",
- version="8.0.0",
+ version="8.0.1",
packages=find_packages(),
entry_points={"console_scripts": ["natsort = natsort.__main__:main"]},
python_requires=">=3.6",