summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Morton <seth.m.morton@gmail.com>2023-04-18 20:35:50 -0700
committerSeth Morton <seth.m.morton@gmail.com>2023-04-18 20:37:53 -0700
commit3b161bec8da7bbcc70e7749b8722891f8385db88 (patch)
tree9a68f4be813455696a5dbfe592dcbef6341e6c2d
parent7df66a2ea0f1dece4dce6091735a69616d9ee09a (diff)
downloadnatsort-3b161bec8da7bbcc70e7749b8722891f8385db88.tar.gz
Remove CHANGELOG from API documentation
This removes the dep on m2r2, and closes #162.
-rw-r--r--CHANGELOG.md5
-rw-r--r--README.rst3
-rw-r--r--docs/changelog.rst2
-rw-r--r--docs/conf.py3
-rw-r--r--docs/requirements.in1
-rw-r--r--docs/requirements.txt9
-rw-r--r--tox.ini1
7 files changed, 8 insertions, 16 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 03adecb..a79119f 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,11 @@
Unreleased
---
+### Changed
+
+- The changelog now only explictly exists in the repository
+ (issue [#162](https://github.com/SethMMorton/natsort/issues/162))
+
[8.3.1] - 2023-03-01
---
diff --git a/README.rst b/README.rst
index f1af055..d196140 100644
--- a/README.rst
+++ b/README.rst
@@ -471,7 +471,7 @@ Seth M. Morton
History
-------
-Please visit the changelog `on GitHub`_ or `in the documentation`_.
+Please visit the changelog `on GitHub`_.
.. _natsort: https://natsort.readthedocs.io/en/stable/index.html
.. _natsorted(): https://natsort.readthedocs.io/en/stable/api.html#natsort.natsorted
@@ -500,7 +500,6 @@ Please visit the changelog `on GitHub`_ or `in the documentation`_.
.. _How Does Natsort Work?: https://github.com/SethMMorton/natsort/wiki/How-Does-Natsort-Work%3F
.. _API: https://natsort.readthedocs.io/en/stable/api.html
.. _on GitHub: https://github.com/SethMMorton/natsort/blob/main/CHANGELOG.md
-.. _in the documentation: https://natsort.readthedocs.io/en/stable/changelog.html
.. _file an issue: https://github.com/SethMMorton/natsort/issues/new
.. _look at this issue describing how to debug: https://github.com/SethMMorton/natsort/issues/13#issuecomment-50422375
.. _controlling the case-sensitivity: https://github.com/SethMMorton/natsort/wiki/Examples-and-Recipes#controlling-case-when-sorting
diff --git a/docs/changelog.rst b/docs/changelog.rst
index 5b079b8..be23251 100644
--- a/docs/changelog.rst
+++ b/docs/changelog.rst
@@ -3,4 +3,4 @@
Changelog
=========
-.. mdinclude:: ../CHANGELOG.md
+Please visit https://github.com/SethMMorton/natsort/blob/main/CHANGELOG.md.
diff --git a/docs/conf.py b/docs/conf.py
index ab9c3ee..3b6d6d5 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -33,7 +33,6 @@ extensions = [
"sphinx.ext.intersphinx",
"sphinx.ext.mathjax",
"sphinx.ext.napoleon",
- "m2r2",
]
autodoc_typehints = "none"
@@ -41,7 +40,7 @@ autodoc_typehints = "none"
templates_path = ["_templates"]
# The suffix of source filenames.
-source_suffix = [".rst", ".md"]
+source_suffix = [".rst"]
# The encoding of source files.
# source_encoding = 'utf-8-sig'
diff --git a/docs/requirements.in b/docs/requirements.in
deleted file mode 100644
index d9ac8d4..0000000
--- a/docs/requirements.in
+++ /dev/null
@@ -1 +0,0 @@
-m2r2
diff --git a/docs/requirements.txt b/docs/requirements.txt
deleted file mode 100644
index e284645..0000000
--- a/docs/requirements.txt
+++ /dev/null
@@ -1,9 +0,0 @@
-#
-# This file is autogenerated by pip-compile
-# To update, run:
-#
-# pip-compile
-#
-docutils==0.16 # via m2r2
-m2r2==0.2.7 # via -r requirements.in
-mistune==0.8.4 # via m2r2
diff --git a/tox.ini b/tox.ini
index 3fa2378..0a28fd0 100644
--- a/tox.ini
+++ b/tox.ini
@@ -72,7 +72,6 @@ skip_install = true
deps =
sphinx
sphinx_rtd_theme
- -r docs/requirements.txt
commands =
{envpython} setup.py build_sphinx
skip_install = true