summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Morton <seth.m.morton@gmail.com>2021-11-03 07:30:30 -0700
committerSeth Morton <seth.m.morton@gmail.com>2021-11-03 07:30:30 -0700
commit40a3f6c625e5e58d4c303c4366e7df2448852943 (patch)
tree84123da0bc640e03ab8fc6664facbcf6d0dde4bd
parent3f12f58231e2c6f87e82f37c73ae6a88a14c4811 (diff)
downloadnatsort-40a3f6c625e5e58d4c303c4366e7df2448852943.tar.gz
Bump version: 7.2.0 → 8.0.08.0.0
-rw-r--r--CHANGELOG.md4
-rw-r--r--docs/conf.py2
-rw-r--r--natsort/__init__.py2
-rw-r--r--setup.cfg2
-rw-r--r--setup.py2
5 files changed, 8 insertions, 4 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 5c51611..263c5f4 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,9 @@
Unreleased
---
+[8.0.0] - 2021-11-03
+---
+
- Re-release 7.2.0 as 8.0.0 because introduction of type hints can break CI
builds (issue #139)
@@ -574,6 +577,7 @@ a pipeline by which to filter
- Sorting algorithm to support floats (including exponentials) and basic version number support
<!---Comparison links-->
+[8.0.0]: https://github.com/SethMMorton/natsort/compare/7.2.0...8.0.0
[7.2.0]: https://github.com/SethMMorton/natsort/compare/7.1.1...7.2.0
[7.1.1]: https://github.com/SethMMorton/natsort/compare/7.1.0...7.1.1
[7.1.0]: https://github.com/SethMMorton/natsort/compare/7.0.1...7.1.0
diff --git a/docs/conf.py b/docs/conf.py
index b5f87d9..1399b98 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -59,7 +59,7 @@ copyright = "2014, Seth M. Morton"
# built documents.
#
# The full version, including alpha/beta/rc tags.
-release = "7.2.0"
+release = "8.0.0"
# The short X.Y version.
version = ".".join(release.split(".")[0:2])
diff --git a/natsort/__init__.py b/natsort/__init__.py
index ea0bca1..c521ff7 100644
--- a/natsort/__init__.py
+++ b/natsort/__init__.py
@@ -23,7 +23,7 @@ from natsort.natsort import (
from natsort.ns_enum import NSType, ns
from natsort.utils import KeyType, NatsortInType, NatsortOutType, chain_functions
-__version__ = "7.2.0"
+__version__ = "8.0.0"
__all__ = [
"natsort_key",
diff --git a/setup.cfg b/setup.cfg
index 6889b6a..c7a1ac6 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,5 @@
[bumpversion]
-current_version = 7.2.0
+current_version = 8.0.0
commit = True
tag = True
tag_name = {new_version}
diff --git a/setup.py b/setup.py
index 9a993f5..25e7aad 100644
--- a/setup.py
+++ b/setup.py
@@ -4,7 +4,7 @@ from setuptools import find_packages, setup
setup(
name="natsort",
- version="7.2.0",
+ version="8.0.0",
packages=find_packages(),
entry_points={"console_scripts": ["natsort = natsort.__main__:main"]},
python_requires=">=3.6",