summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Morton <seth.m.morton@gmail.com>2023-02-27 01:06:37 -0800
committerSeth Morton <seth.m.morton@gmail.com>2023-02-27 01:06:37 -0800
commit4352d7b7b029a2636f8b5a68ebdb9ad86fbd860a (patch)
tree9c6b78e6b6311ea63e9ba6192b2b822b1435a422
parent7b3b8d01b8888b978845407784cf31293217c287 (diff)
downloadnatsort-4352d7b7b029a2636f8b5a68ebdb9ad86fbd860a.tar.gz
Use modern method to create wheels
-rw-r--r--.github/workflows/deploy.yml4
-rw-r--r--tox.ini3
2 files changed, 4 insertions, 3 deletions
diff --git a/.github/workflows/deploy.yml b/.github/workflows/deploy.yml
index 44d45f4..12c2039 100644
--- a/.github/workflows/deploy.yml
+++ b/.github/workflows/deploy.yml
@@ -21,8 +21,8 @@ jobs:
- name: Build Source Distribution and Wheel
run: |
- pip install wheel
- python setup.py sdist --format=gztar bdist_wheel
+ python setup.py sdist --format=gztar
+ pip wheel . -w dist
- name: Publish to PyPI
uses: pypa/gh-action-pypi-publish@release/v1
diff --git a/tox.ini b/tox.ini
index d6a2d98..833d005 100644
--- a/tox.ini
+++ b/tox.ini
@@ -46,7 +46,8 @@ deps =
check-manifest
twine
commands =
- {envpython} setup.py sdist bdist_wheel
+ {envpython} setup.py sdist
+ pip wheel . -w dist
flake8
check-manifest --ignore ".github*,*.md,.coveragerc"
twine check dist/*