summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Morton <seth.m.morton@gmail.com>2023-02-27 09:57:49 -0800
committerSeth Morton <seth.m.morton@gmail.com>2023-02-27 09:57:49 -0800
commit451244d19d36df152d416003acf47ce538c8beaf (patch)
treefcfab65efb0edc9d9ce47742bd7ca445d862dd54
parent3dc133c38b369700de0af471a49d53e558a37a38 (diff)
downloadnatsort-451244d19d36df152d416003acf47ce538c8beaf.tar.gz
Bump version: 8.2.0 → 8.3.0
-rw-r--r--CHANGELOG.md4
-rw-r--r--docs/conf.py2
-rw-r--r--natsort/__init__.py2
-rw-r--r--setup.cfg2
-rw-r--r--setup.py2
5 files changed, 8 insertions, 4 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 4278428..3560a5b 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,9 @@
Unreleased
---
+[8.3.0] - 2023-02-27
+---
+
### Added
- The `PRESORT` option to the `ns` enum to attain consistent
sort order in certain corner cases (Issue
@@ -626,6 +629,7 @@ a pipeline by which to filter
- Sorting algorithm to support floats (including exponentials) and basic version number support
<!---Comparison links-->
+[8.3.0]: https://github.com/SethMMorton/natsort/compare/8.2.0...8.3.0
[8.2.0]: https://github.com/SethMMorton/natsort/compare/8.1.0...8.2.0
[8.1.0]: https://github.com/SethMMorton/natsort/compare/8.0.2...8.1.0
[8.0.2]: https://github.com/SethMMorton/natsort/compare/8.0.1...8.0.2
diff --git a/docs/conf.py b/docs/conf.py
index 941b27e..aef6107 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -59,7 +59,7 @@ copyright = "2014, Seth M. Morton"
# built documents.
#
# The full version, including alpha/beta/rc tags.
-release = "8.2.0"
+release = "8.3.0"
# The short X.Y version.
version = ".".join(release.split(".")[0:2])
diff --git a/natsort/__init__.py b/natsort/__init__.py
index 5d8a911..d54c6cb 100644
--- a/natsort/__init__.py
+++ b/natsort/__init__.py
@@ -23,7 +23,7 @@ from natsort.natsort import (
from natsort.ns_enum import NSType, ns
from natsort.utils import KeyType, NatsortInType, NatsortOutType, chain_functions
-__version__ = "8.2.0"
+__version__ = "8.3.0"
__all__ = [
"natsort_key",
diff --git a/setup.cfg b/setup.cfg
index 020c32f..412be68 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,5 @@
[bumpversion]
-current_version = 8.2.0
+current_version = 8.3.0
commit = True
tag = True
tag_name = {new_version}
diff --git a/setup.py b/setup.py
index 59d31da..9c653fb 100644
--- a/setup.py
+++ b/setup.py
@@ -4,7 +4,7 @@ from setuptools import find_packages, setup
setup(
name="natsort",
- version="8.2.0",
+ version="8.3.0",
packages=find_packages(),
entry_points={"console_scripts": ["natsort = natsort.__main__:main"]},
python_requires=">=3.7",