summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Morton <seth.m.morton@gmail.com>2022-09-01 14:44:15 -0700
committerSeth Morton <seth.m.morton@gmail.com>2022-09-01 14:44:15 -0700
commit48b91687f2c98feabeb6d449134f5d104f46956e (patch)
treea7cfb44b6f057039c4b05ce05aebe3d2438ea84f
parent5c52a8888c2cb0c3f08192e2684851e0253b4437 (diff)
downloadnatsort-48b91687f2c98feabeb6d449134f5d104f46956e.tar.gz
Bump version: 8.1.0 → 8.2.08.2.0
-rw-r--r--CHANGELOG.md4
-rw-r--r--docs/conf.py2
-rw-r--r--natsort/__init__.py2
-rw-r--r--setup.cfg2
-rw-r--r--setup.py2
5 files changed, 8 insertions, 4 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index e326486..b20931c 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,9 @@
Unreleased
---
+[8.2.0] - 2022-09-01
+---
+
### Changed
- Auto-coerce `pathlib.Path` objects to `str` since it is the least astonishing
behavior ([@Gilthans](https://github.com/Gilthans), issues #152, #153)
@@ -603,6 +606,7 @@ a pipeline by which to filter
- Sorting algorithm to support floats (including exponentials) and basic version number support
<!---Comparison links-->
+[8.2.0]: https://github.com/SethMMorton/natsort/compare/8.1.0...8.2.0
[8.1.0]: https://github.com/SethMMorton/natsort/compare/8.0.2...8.1.0
[8.0.2]: https://github.com/SethMMorton/natsort/compare/8.0.1...8.0.2
[8.0.1]: https://github.com/SethMMorton/natsort/compare/8.0.0...8.0.1
diff --git a/docs/conf.py b/docs/conf.py
index 6ec4db9..941b27e 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -59,7 +59,7 @@ copyright = "2014, Seth M. Morton"
# built documents.
#
# The full version, including alpha/beta/rc tags.
-release = "8.1.0"
+release = "8.2.0"
# The short X.Y version.
version = ".".join(release.split(".")[0:2])
diff --git a/natsort/__init__.py b/natsort/__init__.py
index 911c11b..5d8a911 100644
--- a/natsort/__init__.py
+++ b/natsort/__init__.py
@@ -23,7 +23,7 @@ from natsort.natsort import (
from natsort.ns_enum import NSType, ns
from natsort.utils import KeyType, NatsortInType, NatsortOutType, chain_functions
-__version__ = "8.1.0"
+__version__ = "8.2.0"
__all__ = [
"natsort_key",
diff --git a/setup.cfg b/setup.cfg
index a99791c..f909753 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,5 @@
[bumpversion]
-current_version = 8.1.0
+current_version = 8.2.0
commit = True
tag = True
tag_name = {new_version}
diff --git a/setup.py b/setup.py
index cce30ec..314565e 100644
--- a/setup.py
+++ b/setup.py
@@ -4,7 +4,7 @@ from setuptools import find_packages, setup
setup(
name="natsort",
- version="8.1.0",
+ version="8.2.0",
packages=find_packages(),
entry_points={"console_scripts": ["natsort = natsort.__main__:main"]},
python_requires=">=3.6",