summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Morton <seth.m.morton@gmail.com>2021-01-24 21:18:17 -0800
committerSeth Morton <seth.m.morton@gmail.com>2021-01-24 21:18:17 -0800
commit4e47f82856822ac776b4874747852b99edb79d9e (patch)
tree38bd4a91bb7c5c9d8ac1b44ef02080db7719bacf
parent5e095bb5dc00bb3cb5e7ca835f3e001870043ae1 (diff)
downloadnatsort-4e47f82856822ac776b4874747852b99edb79d9e.tar.gz
Bump version: 7.1.0 → 7.1.17.1.1
-rw-r--r--CHANGELOG.md4
-rw-r--r--docs/conf.py2
-rw-r--r--natsort/__init__.py2
-rw-r--r--setup.cfg3
-rw-r--r--setup.py2
5 files changed, 8 insertions, 5 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index ecef889..4e0c86d 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,9 @@
Unreleased
---
+[7.1.1] - 2021-01-24
+---
+
### Changed
- Use GitHub Actions instead of Travis-CI (issue #125)
- No longer pin testing dependencies (issue #126)
@@ -557,6 +560,7 @@ a pipeline by which to filter
- Sorting algorithm to support floats (including exponentials) and basic version number support
<!---Comparison links-->
+[7.1.1]: https://github.com/SethMMorton/natsort/compare/7.1.0...7.1.1
[7.1.0]: https://github.com/SethMMorton/natsort/compare/7.0.1...7.1.0
[7.0.1]: https://github.com/SethMMorton/natsort/compare/7.0.0...7.0.1
[7.0.0]: https://github.com/SethMMorton/natsort/compare/6.2.0...7.0.0
diff --git a/docs/conf.py b/docs/conf.py
index 4e87392..05919ec 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -58,7 +58,7 @@ copyright = "2014, Seth M. Morton"
# built documents.
#
# The full version, including alpha/beta/rc tags.
-release = "7.1.0"
+release = "7.1.1"
# The short X.Y version.
version = ".".join(release.split(".")[0:2])
diff --git a/natsort/__init__.py b/natsort/__init__.py
index 43c09f2..8c8f87f 100644
--- a/natsort/__init__.py
+++ b/natsort/__init__.py
@@ -21,7 +21,7 @@ from natsort.natsort import (
)
from natsort.utils import chain_functions
-__version__ = "7.1.0"
+__version__ = "7.1.1"
__all__ = [
"natsort_key",
diff --git a/setup.cfg b/setup.cfg
index 667f2dd..a045246 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,5 @@
[bumpversion]
-current_version = 7.1.0
+current_version = 7.1.1
commit = True
tag = True
tag_name = {new_version}
@@ -63,4 +63,3 @@ exclude =
dist,
docs,
.venv
-
diff --git a/setup.py b/setup.py
index d521491..ed1362a 100644
--- a/setup.py
+++ b/setup.py
@@ -4,7 +4,7 @@ from setuptools import find_packages, setup
setup(
name="natsort",
- version="7.1.0",
+ version="7.1.1",
packages=find_packages(),
entry_points={"console_scripts": ["natsort = natsort.__main__:main"]},
python_requires=">=3.4",