summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Morton <seth.m.morton@gmail.com>2021-10-24 09:52:25 -0700
committerSeth Morton <seth.m.morton@gmail.com>2021-10-24 09:52:25 -0700
commit7a44a5e31ae0e7d036270fe67c66cfe63d6c239b (patch)
tree0e0e6d7b665628162e9ba241504afe16426c37f6
parentcd0520fc8e462643f59ef0bee77b509021b3108e (diff)
downloadnatsort-7a44a5e31ae0e7d036270fe67c66cfe63d6c239b.tar.gz
Remove support for Python 3.5 and 3.4
-rw-r--r--.github/workflows/tests.yml2
-rw-r--r--CHANGELOG.md4
-rw-r--r--setup.py2
-rw-r--r--tox.ini2
4 files changed, 7 insertions, 3 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index 3263030..ce64b65 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -15,7 +15,7 @@ jobs:
runs-on: ${{ matrix.os }}
strategy:
matrix:
- python-version: [3.5, 3.6, 3.7, 3.8, 3.9]
+ python-version: [3.6, 3.7, 3.8, 3.9]
os: [ubuntu-latest]
extras: [false]
include:
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 4e0c86d..5683cb5 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,10 @@
Unreleased
---
+### Removed
+
+ - Support for Python 3.4 and Python 3.5
+
[7.1.1] - 2021-01-24
---
diff --git a/setup.py b/setup.py
index ed1362a..793c517 100644
--- a/setup.py
+++ b/setup.py
@@ -7,6 +7,6 @@ setup(
version="7.1.1",
packages=find_packages(),
entry_points={"console_scripts": ["natsort = natsort.__main__:main"]},
- python_requires=">=3.4",
+ python_requires=">=3.6",
extras_require={"fast": ["fastnumbers >= 2.0.0"], "icu": ["PyICU >= 1.0.0"]},
)
diff --git a/tox.ini b/tox.ini
index f89ee8f..9db8e4e 100644
--- a/tox.ini
+++ b/tox.ini
@@ -5,7 +5,7 @@
[tox]
envlist =
- flake8, mypy, py35, py36, py37, py38, py39
+ flake8, mypy, py36, py37, py38, py39
# Other valid evironments are:
# docs
# release