summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Morton <seth.m.morton@gmail.com>2023-02-27 00:58:52 -0800
committerSeth Morton <seth.m.morton@gmail.com>2023-02-27 00:58:52 -0800
commit7afcdbe46586b1bb672aa1a43f84446c2184ed4c (patch)
tree2f32c6a978523296fbe6e0639a715e7e8b7651d8
parent9bec9257a931f491953005241d6cda20d427b2bc (diff)
downloadnatsort-7afcdbe46586b1bb672aa1a43f84446c2184ed4c.tar.gz
Update development documentation
-rw-r--r--CONTRIBUTING.md13
-rw-r--r--RELEASING.md11
2 files changed, 12 insertions, 12 deletions
diff --git a/CONTRIBUTING.md b/CONTRIBUTING.md
index 05f8492..696d60d 100644
--- a/CONTRIBUTING.md
+++ b/CONTRIBUTING.md
@@ -7,11 +7,16 @@ robust algorithm. Contributions that change the public API of
less usable after the contribution and is backwards-compatible (unless there is
a good reason not to be).
+Located in the `dev/` folder is development collateral such as formatting and
+patching scripts. The only development collateral not in the `dev/`
+folder are those files that are expected to exist in the the top-level directory
+(such as `setup.py`, `tox.ini`, and CI configuration). All of these scripts
+can either be run with the python stdandard library, or have hooks in `tox`.
+
I do not have strong opinions on how one should contribute, so
I have copy/pasted some text verbatim from the
[Contributor's Guide](http://docs.python-requests.org/en/latest/dev/contributing/) section of
-[Kenneth Reitz's](http://docs.python-requests.org/en/latest/dev/contributing/)
-excellent [requests](https://github.com/kennethreitz/requests) library in
+the [requests](https://github.com/kennethreitz/requests) library in
lieu of coming up with my own.
> ### Steps for Submitting Code
@@ -27,7 +32,7 @@ lieu of coming up with my own.
> - Make your change.
> - Run the entire test suite again, confirming that all tests pass including the
ones you just added.
-> - Send a GitHub Pull Request to the main repository's master branch.
+> - Send a GitHub Pull Request to the main repository's main branch.
GitHub Pull Requests are the expected method of code collaboration on this project.
> ### Documentation Contributions
@@ -40,5 +45,3 @@ lieu of coming up with my own.
> When contributing documentation, please do your best to follow the style of the
documentation files. This means a soft-limit of 79 characters wide in your text
files and a semi-formal, yet friendly and approachable, prose style.
-
-> When presenting Python code, use single-quoted strings ('hello' instead of "hello").
diff --git a/RELEASING.md b/RELEASING.md
index 1c6932f..9f510c6 100644
--- a/RELEASING.md
+++ b/RELEASING.md
@@ -1,8 +1,8 @@
# Release Checklist
-- [ ] Get master to the appropriate code release state.
- [Travis CI](https://travis-ci.com/SethMMorton/natsort) must be passing:
- [![Build Status](https://travis-ci.com/SethMMorton/natsort.svg?branch=master)](https://travis-ci.com/SethMMorton/natsort)
+- [ ] Get main to the appropriate code release state.
+ [GitHub Actions](https://github.com/SethMMorton/natsort/actions) must be passing:
+ [![Build Status](https://github.com/SethMMorton/natsort/workflows/Tests/badge.svg)](https://github.com/SethMMorton/natsort/actions)
- [ ] Ensure that the `CHANGELOG.md` includes the changes made since last release.
Please follow the style outlined in https://keepachangelog.com/.
@@ -23,16 +23,13 @@
git push
```
-- [ ] Check that the [Travis CI build](https://travis-ci.com/SethMMorton/natsort) has
- deployed correctly to [the test PyPI](https://test.pypi.org/project/natsort/#history).
-
- [ ] Push the tag:
```bash
git push --tags
```
-- [ ] Check that the tagged [Travis CI build](https://travis-ci.com/SethMMorton/natsort) has
+- [ ] Check that the tagged [GitHub Actions build](https://github.com/SethMMorton/natsort/actions) has
deployed correctly to [PyPI](https://pypi.org/project/natsort/#history).
- [ ] Check installation: