summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Morton <seth.m.morton@gmail.com>2021-11-02 21:01:48 -0700
committerSeth Morton <seth.m.morton@gmail.com>2021-11-02 21:01:48 -0700
commita2da99cd10432ec130c69d2b94db12299679aa3f (patch)
tree0c6197becd8700117a760a6a12d8c52165bfd5c3
parent976ae8c293e486b3b769c0983d3ab4dd16c0d34e (diff)
downloadnatsort-a2da99cd10432ec130c69d2b94db12299679aa3f.tar.gz
Bump version: 7.1.1 → 7.2.07.2.0
-rw-r--r--CHANGELOG.md4
-rw-r--r--docs/conf.py2
-rw-r--r--natsort/__init__.py2
-rw-r--r--setup.cfg3
-rw-r--r--setup.py2
5 files changed, 8 insertions, 5 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index e6aa51a..8ed7fed 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,9 @@
Unreleased
---
+[7.2.0] - 2021-11-02
+---
+
### Added
- Type hints (contributions from [@thethiny](https://github.com/thethiny) and
[@domdfcoding](https://github.com/domdfcoding), issues #132, #135, and #138)
@@ -568,6 +571,7 @@ a pipeline by which to filter
- Sorting algorithm to support floats (including exponentials) and basic version number support
<!---Comparison links-->
+[7.2.0]: https://github.com/SethMMorton/natsort/compare/7.1.1...7.2.0
[7.1.1]: https://github.com/SethMMorton/natsort/compare/7.1.0...7.1.1
[7.1.0]: https://github.com/SethMMorton/natsort/compare/7.0.1...7.1.0
[7.0.1]: https://github.com/SethMMorton/natsort/compare/7.0.0...7.0.1
diff --git a/docs/conf.py b/docs/conf.py
index feab38e..b5f87d9 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -59,7 +59,7 @@ copyright = "2014, Seth M. Morton"
# built documents.
#
# The full version, including alpha/beta/rc tags.
-release = "7.1.1"
+release = "7.2.0"
# The short X.Y version.
version = ".".join(release.split(".")[0:2])
diff --git a/natsort/__init__.py b/natsort/__init__.py
index 4207f79..ea0bca1 100644
--- a/natsort/__init__.py
+++ b/natsort/__init__.py
@@ -23,7 +23,7 @@ from natsort.natsort import (
from natsort.ns_enum import NSType, ns
from natsort.utils import KeyType, NatsortInType, NatsortOutType, chain_functions
-__version__ = "7.1.1"
+__version__ = "7.2.0"
__all__ = [
"natsort_key",
diff --git a/setup.cfg b/setup.cfg
index f90f59d..6889b6a 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,5 @@
[bumpversion]
-current_version = 7.1.1
+current_version = 7.2.0
commit = True
tag = True
tag_name = {new_version}
@@ -67,4 +67,3 @@ exclude =
[mypy-icu]
ignore_missing_imports = True
-
diff --git a/setup.py b/setup.py
index 2d27ae0..9a993f5 100644
--- a/setup.py
+++ b/setup.py
@@ -4,7 +4,7 @@ from setuptools import find_packages, setup
setup(
name="natsort",
- version="7.1.1",
+ version="7.2.0",
packages=find_packages(),
entry_points={"console_scripts": ["natsort = natsort.__main__:main"]},
python_requires=">=3.6",