summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Morton <seth.m.morton@gmail.com>2022-01-30 19:19:44 -0800
committerSeth Morton <seth.m.morton@gmail.com>2022-01-30 19:19:44 -0800
commite3c32f5638bf3a0e9a23633495269bea0e75d379 (patch)
tree23fa16eb6e44ec6e26d9a40eacd84ac968242b71
parent473348f820941cae18d377bde986e56ecc0ff37e (diff)
downloadnatsort-e3c32f5638bf3a0e9a23633495269bea0e75d379.tar.gz
Bump version: 8.0.2 → 8.1.08.1.0
-rw-r--r--CHANGELOG.md4
-rw-r--r--docs/conf.py2
-rw-r--r--natsort/__init__.py2
-rw-r--r--setup.cfg2
-rw-r--r--setup.py2
5 files changed, 8 insertions, 4 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index b1475fc..d83289d 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,9 @@
Unreleased
---
+[8.1.0] - 2022-01-30
+---
+
### Changed
- When using `ns.PATH`, only split off a maximum of two suffixes from
a file name (issues #145, #146).
@@ -594,6 +597,7 @@ a pipeline by which to filter
- Sorting algorithm to support floats (including exponentials) and basic version number support
<!---Comparison links-->
+[8.1.0]: https://github.com/SethMMorton/natsort/compare/8.0.2...8.1.0
[8.0.2]: https://github.com/SethMMorton/natsort/compare/8.0.1...8.0.2
[8.0.1]: https://github.com/SethMMorton/natsort/compare/8.0.0...8.0.1
[8.0.0]: https://github.com/SethMMorton/natsort/compare/7.2.0...8.0.0
diff --git a/docs/conf.py b/docs/conf.py
index f19e176..6ec4db9 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -59,7 +59,7 @@ copyright = "2014, Seth M. Morton"
# built documents.
#
# The full version, including alpha/beta/rc tags.
-release = "8.0.2"
+release = "8.1.0"
# The short X.Y version.
version = ".".join(release.split(".")[0:2])
diff --git a/natsort/__init__.py b/natsort/__init__.py
index 0c3a07d..911c11b 100644
--- a/natsort/__init__.py
+++ b/natsort/__init__.py
@@ -23,7 +23,7 @@ from natsort.natsort import (
from natsort.ns_enum import NSType, ns
from natsort.utils import KeyType, NatsortInType, NatsortOutType, chain_functions
-__version__ = "8.0.2"
+__version__ = "8.1.0"
__all__ = [
"natsort_key",
diff --git a/setup.cfg b/setup.cfg
index c97939e..6fd9d1d 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,5 @@
[bumpversion]
-current_version = 8.0.2
+current_version = 8.1.0
commit = True
tag = True
tag_name = {new_version}
diff --git a/setup.py b/setup.py
index e74e817..cce30ec 100644
--- a/setup.py
+++ b/setup.py
@@ -4,7 +4,7 @@ from setuptools import find_packages, setup
setup(
name="natsort",
- version="8.0.2",
+ version="8.1.0",
packages=find_packages(),
entry_points={"console_scripts": ["natsort = natsort.__main__:main"]},
python_requires=">=3.6",