summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-11-07 21:36:35 -0800
committerJon Dufresne <jon.dufresne@gmail.com>2018-11-10 10:50:33 -0800
commit36cd8f38e1f1725dfc0078b6f42e35855372bb93 (patch)
tree8ec58e60db64787752dc13fb55b97bddb1956cc6 /setup.py
parent1374b6d2de18e11c0ce6e8aab1fcd09cc70a83dd (diff)
downloadnatsort-36cd8f38e1f1725dfc0078b6f42e35855372bb93.tar.gz
Drop support for EOL Pythons
Support matrix now matches the test matrix from 6233f07bf303d442b39ac677fa6079acc64834a6. By matching these, helps to ensure all supported Python do indeed work. Python 2.6 and 3.3 are end of life. They are no longer receiving bug fixes, including for security issues. Python 2.6 went EOL on 2013-10-29 and on 2017-09-29. For additional details on support Python versions, see: Supported: https://devguide.python.org/#status-of-python-branches EOL: https://devguide.python.org/devcycle/#end-of-life-branches Removing support for EOL Pythons will reduce testing and maintenance resources while allowing the library to move towards a modern Python 3 style. Using pypinfo, we can show the PyPI download statistics, show very low numbers for EOL Pythons. | python_version | percent | download_count | | -------------- | ------: | -------------: | | 2.7 | 48.94% | 37,036 | | 3.6 | 26.58% | 20,113 | | 3.5 | 15.38% | 11,642 | | 3.4 | 5.93% | 4,488 | | 3.7 | 3.13% | 2,365 | | 3.3 | 0.03% | 21 | | 2.6 | 0.01% | 9 | | Total | | 75,674 |
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index bef9357..963c483 100644
--- a/setup.py
+++ b/setup.py
@@ -5,10 +5,10 @@ setup(
name='natsort',
version='5.4.1',
packages=find_packages(),
- install_requires=["argparse; python_version < '2.7'"],
entry_points={'console_scripts': ['natsort = natsort.__main__:main']},
+ python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
extras_require={
- 'fast': ["fastnumbers >= 2.0.0; python_version > '2.6'"],
+ 'fast': ["fastnumbers >= 2.0.0"],
'icu': ["PyICU >= 1.0.0"]
}
)