summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG.md4
-rw-r--r--docs/conf.py2
-rw-r--r--natsort/__init__.py2
-rw-r--r--setup.cfg3
-rw-r--r--setup.py2
5 files changed, 8 insertions, 5 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 4d4138d..8c3c187 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,9 @@
Unreleased
---
+[7.0.1] - 2020-01-27
+---
+
### Fixed
- Bug where that caused incorrect sorting when using locales
that have a `"."` character as the thousands separator.
@@ -527,6 +530,7 @@ a pipeline by which to filter
- Sorting algorithm to support floats (including exponentials) and basic version number support
<!---Comparison links-->
+[7.0.1]: https://github.com/SethMMorton/natsort/compare/7.0.0...7.0.1
[7.0.0]: https://github.com/SethMMorton/natsort/compare/6.2.0...7.0.0
[6.2.0]: https://github.com/SethMMorton/natsort/compare/6.1.0...6.2.0
[6.1.0]: https://github.com/SethMMorton/natsort/compare/6.0.0...6.1.0
diff --git a/docs/conf.py b/docs/conf.py
index 4dca26d..f9510d4 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -58,7 +58,7 @@ copyright = '2014, Seth M. Morton'
# built documents.
#
# The full version, including alpha/beta/rc tags.
-release = '7.0.0'
+release = '7.0.1'
# The short X.Y version.
version = '.'.join(release.split('.')[0:2])
diff --git a/natsort/__init__.py b/natsort/__init__.py
index 26cd0a8..88603d3 100644
--- a/natsort/__init__.py
+++ b/natsort/__init__.py
@@ -18,7 +18,7 @@ from natsort.natsort import (
)
from natsort.utils import chain_functions
-__version__ = "7.0.0"
+__version__ = "7.0.1"
__all__ = [
"natsort_key",
diff --git a/setup.cfg b/setup.cfg
index 07fbfd7..4e5e8f7 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,5 @@
[bumpversion]
-current_version = 7.0.0
+current_version = 7.0.1
commit = True
tag = True
tag_name = {new_version}
@@ -62,4 +62,3 @@ exclude =
dist,
docs,
.venv
-
diff --git a/setup.py b/setup.py
index c5ca32e..5b9858d 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@
from setuptools import find_packages, setup
setup(
name='natsort',
- version='7.0.0',
+ version='7.0.1',
packages=find_packages(),
entry_points={'console_scripts': ['natsort = natsort.__main__:main']},
python_requires=">=3.4",