summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG.md4
-rw-r--r--docs/conf.py2
-rw-r--r--natsort/__init__.py2
-rw-r--r--setup.cfg3
-rw-r--r--setup.py2
5 files changed, 9 insertions, 4 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index c2348dc..c3a7551 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,9 @@
Unreleased
---
+[7.1.0] - 2020-11-19
+---
+
### Added
- ``os_sorted``, ``os_sort_keygen``, and ``os_sort_key`` to better support
sorting like the file browser on the current operating system - this
@@ -547,6 +550,7 @@ a pipeline by which to filter
- Sorting algorithm to support floats (including exponentials) and basic version number support
<!---Comparison links-->
+[7.1.0]: https://github.com/SethMMorton/natsort/compare/7.0.1...7.1.0
[7.0.1]: https://github.com/SethMMorton/natsort/compare/7.0.0...7.0.1
[7.0.0]: https://github.com/SethMMorton/natsort/compare/6.2.0...7.0.0
[6.2.0]: https://github.com/SethMMorton/natsort/compare/6.1.0...6.2.0
diff --git a/docs/conf.py b/docs/conf.py
index f9510d4..7e75561 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -58,7 +58,7 @@ copyright = '2014, Seth M. Morton'
# built documents.
#
# The full version, including alpha/beta/rc tags.
-release = '7.0.1'
+release = '7.1.0'
# The short X.Y version.
version = '.'.join(release.split('.')[0:2])
diff --git a/natsort/__init__.py b/natsort/__init__.py
index ad4a609..43c09f2 100644
--- a/natsort/__init__.py
+++ b/natsort/__init__.py
@@ -21,7 +21,7 @@ from natsort.natsort import (
)
from natsort.utils import chain_functions
-__version__ = "7.0.1"
+__version__ = "7.1.0"
__all__ = [
"natsort_key",
diff --git a/setup.cfg b/setup.cfg
index 3951e24..667f2dd 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,5 @@
[bumpversion]
-current_version = 7.0.1
+current_version = 7.1.0
commit = True
tag = True
tag_name = {new_version}
@@ -63,3 +63,4 @@ exclude =
dist,
docs,
.venv
+
diff --git a/setup.py b/setup.py
index 5b9858d..a15a580 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@
from setuptools import find_packages, setup
setup(
name='natsort',
- version='7.0.1',
+ version='7.1.0',
packages=find_packages(),
entry_points={'console_scripts': ['natsort = natsort.__main__:main']},
python_requires=">=3.4",