summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG.md4
-rw-r--r--docs/conf.py2
-rw-r--r--natsort/__init__.py2
-rw-r--r--setup.cfg7
-rw-r--r--setup.py2
5 files changed, 11 insertions, 6 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 39c0ce7..d230e19 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,9 @@
Unreleased
---
+[6.2.0] - 2019-11-13
+---
+
### Added
- Support for Python 3.8 ([@hugovk](https://github.com/hugovk), issue #104)
@@ -504,6 +507,7 @@ a pipeline by which to filter
- Sorting algorithm to support floats (including exponentials) and basic version number support
<!---Comparison links-->
+[6.2.0]: https://github.com/SethMMorton/natsort/compare/6.1.0...6.2.0
[6.1.0]: https://github.com/SethMMorton/natsort/compare/6.0.0...6.1.0
[6.0.0]: https://github.com/SethMMorton/natsort/compare/5.5.0...6.0.0
[5.5.0]: https://github.com/SethMMorton/natsort/compare/5.4.1...5.5.0
diff --git a/docs/conf.py b/docs/conf.py
index b746a90..31f1fed 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -58,7 +58,7 @@ copyright = u'2014, Seth M. Morton'
# built documents.
#
# The full version, including alpha/beta/rc tags.
-release = '6.1.0'
+release = '6.2.0'
# The short X.Y version.
version = '.'.join(release.split('.')[0:2])
diff --git a/natsort/__init__.py b/natsort/__init__.py
index c27c7de..6cb28f5 100644
--- a/natsort/__init__.py
+++ b/natsort/__init__.py
@@ -24,7 +24,7 @@ from natsort.utils import chain_functions
if float(sys.version[:3]) < 3:
from natsort.natsort import natcmp
-__version__ = "6.1.0"
+__version__ = "6.2.0"
__all__ = [
"natsort_key",
diff --git a/setup.cfg b/setup.cfg
index 2727947..bc72bf6 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,5 @@
[bumpversion]
-current_version = 6.1.0
+current_version = 6.2.0
commit = True
tag = True
tag_name = {new_version}
@@ -58,7 +58,7 @@ max-line-length = 89
import-order-style = pycharm
doctests = True
max-complexity = 10
-exclude =
+exclude =
natsort.egg-info,
.tox,
.cache,
@@ -68,4 +68,5 @@ exclude =
dist,
docs,
.venv,
- natsort/compat/py23.py
+ natsort/compat/py23.py
+
diff --git a/setup.py b/setup.py
index c732bea..220eadc 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@
from setuptools import find_packages, setup
setup(
name='natsort',
- version='6.1.0',
+ version='6.2.0',
packages=find_packages(),
entry_points={'console_scripts': ['natsort = natsort.__main__:main']},
python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",