summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Houghton <alastair@alastairs-place.net>2019-01-02 10:39:16 +0000
committerAlastair Houghton <alastair@alastairs-place.net>2019-01-02 10:39:16 +0000
commit5d283cb59ea159dbb385e04b5c0f90d77f9c7ddd (patch)
treeb96c767ea008d9464426573f7f316b41e02e0984
parent4fa0e314ae1fc292a2b8afd37f31e9323bccbfea (diff)
downloadnetifaces-git-5d283cb59ea159dbb385e04b5c0f90d77f9c7ddd.tar.gz
Updated build script and added release instructions.
-rw-r--r--RELEASING26
-rwxr-xr-xbuild-osx2
2 files changed, 27 insertions, 1 deletions
diff --git a/RELEASING b/RELEASING
new file mode 100644
index 0000000..f9b93a5
--- /dev/null
+++ b/RELEASING
@@ -0,0 +1,26 @@
+Release Instructions
+====================
+
+First, update the CHANGELOG as well as README.rst and setup.py.
+
+Next, commit any changes for the release, then tag the release with
+
+ git tag release_a_b_c
+
+where the version number is a.b.c. Make sure you push with the --tags
+option to get the tag back onto Github.
+
+Now wait for Travis and Appveyor to complete their builds; Appveyor in
+particular builds the Windows wheels, so you can't complete a release
+until it has finished.
+
+Finally, when the release is complete, run
+
+ ./build-manylinux1
+ ./build-osx
+ ./fetch-win32-wheels
+
+and then upload using
+
+ twine upload dist/netifaces-a.b.c.tar.gz wheelhouse/netifaces-a.b.c-*.whl
+
diff --git a/build-osx b/build-osx
index 35da8dd..c8ae0d7 100755
--- a/build-osx
+++ b/build-osx
@@ -7,7 +7,7 @@ fi
eval "$(pyenv init -)"
-VERSIONS="2.7.10 3.6.2"
+VERSIONS="2.7.10 3.6.2 3.7.1"
for version in $VERSIONS; do
pyenv install -s "$version"