summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Houghton <alastair@alastairs-place.net>2020-05-19 19:44:24 +0100
committerGitHub <noreply@github.com>2020-05-19 19:44:24 +0100
commit66605c0dc9e2085fae2896c7df549ca448a5a5c1 (patch)
treef3f66187c4eb948d8d8e5cbc66c9c9597eb4d285
parent101586e75225dd00c3b4a9f154ad7085256f3c15 (diff)
parent67569d24f043750a6333eb754f55a59f7fd7dea1 (diff)
downloadnetifaces-git-66605c0dc9e2085fae2896c7df549ca448a5a5c1.tar.gz
Merge pull request #54 from chugcup/py38-building
Added Windows/Linux Python 3.8 builds to CI pipeline
-rw-r--r--.travis.yml4
-rw-r--r--appveyor.yml3
-rwxr-xr-xfetch-win32-wheels4
-rw-r--r--pypi_windows_packages.bat6
-rw-r--r--setup.py6
5 files changed, 18 insertions, 5 deletions
diff --git a/.travis.yml b/.travis.yml
index 3b6ed94..13e79c7 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -32,6 +32,10 @@ matrix:
python: 3.5
- os: linux
python: 3.6
+ - os: linux
+ python: 3.7
+ - os: linux
+ python: 3.8
- os: osx
language: generic
env: PYTHON_VERSION=3.6.2
diff --git a/appveyor.yml b/appveyor.yml
index c6b4496..3137685 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -8,6 +8,9 @@ environment:
- PYTHON: "C:\\Python36-x64"
- PYTHON: "C:\\Python37"
- PYTHON: "C:\\Python37-x64"
+ - PYTHON: "C:\\Python38"
+ - PYTHON: "C:\\Python38-x64"
+
install:
- "%PYTHON%\\python.exe -m pip install wheel ."
diff --git a/fetch-win32-wheels b/fetch-win32-wheels
index ab39321..45ea8e0 100755
--- a/fetch-win32-wheels
+++ b/fetch-win32-wheels
@@ -15,8 +15,8 @@ fi
niversion=$1
artifact_url="https://ci.appveyor.com/api/projects/al45tair/netifaces/artifacts"
-win32_versions="27 34 35 36 37"
-amd64_versions="36 37"
+win32_versions="27 34 35 36 37 38"
+amd64_versions="36 37 38"
for version in $win32_versions; do
wheel=netifaces-$niversion-cp$version-cp${version}m-win32.whl
diff --git a/pypi_windows_packages.bat b/pypi_windows_packages.bat
index 50cf652..e543008 100644
--- a/pypi_windows_packages.bat
+++ b/pypi_windows_packages.bat
@@ -1,6 +1,12 @@
C:\Python27\python.exe setup.py clean bdist_egg bdist_wininst bdist_wheel %*
C:\Python34\python.exe setup.py clean bdist_egg bdist_wininst bdist_wheel %*
C:\Python35\python.exe setup.py clean bdist_egg bdist_wininst bdist_wheel %*
+C:\Python36\python.exe setup.py clean bdist_egg bdist_wininst bdist_wheel %*
+C:\Python37\python.exe setup.py clean bdist_egg bdist_wininst bdist_wheel %*
+C:\Python38\python.exe setup.py clean bdist_egg bdist_wininst bdist_wheel %*
C:\Python27_32\python.exe setup.py clean bdist_egg bdist_wininst bdist_wheel %*
C:\Python34_32\python.exe setup.py clean bdist_egg bdist_wininst bdist_wheel %*
C:\Python35_32\python.exe setup.py clean bdist_egg bdist_wininst bdist_wheel %*
+C:\Python36_32\python.exe setup.py clean bdist_egg bdist_wininst bdist_wheel %*
+C:\Python37_32\python.exe setup.py clean bdist_egg bdist_wininst bdist_wheel %*
+C:\Python38_32\python.exe setup.py clean bdist_egg bdist_wininst bdist_wheel %*
diff --git a/setup.py b/setup.py
index 54b809e..7766f26 100644
--- a/setup.py
+++ b/setup.py
@@ -589,12 +589,12 @@ setup (name='netifaces',
'Topic :: System :: Networking',
'Programming Language :: Python',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.5',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6'
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8'
],
ext_modules=[iface_mod])