summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Houghton <alastair@alastairs-place.net>2018-05-02 08:08:09 +0100
committerGitHub <noreply@github.com>2018-05-02 08:08:09 +0100
commitae1dce4408aebc82180f6f65802d697679b2b335 (patch)
tree8dfd29c0b2a47be44bdb9cc8897ab03810566022
parent55d6449d0f7890aae1f512d9512cb2c83cd3aacd (diff)
parent776424480b337ae498ecdc0422c97fc96fe0c9e1 (diff)
downloadnetifaces-git-ae1dce4408aebc82180f6f65802d697679b2b335.tar.gz
Merge pull request #7 from jlaine/close-readme-file
Close README.rst after reading it
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 80ae7ae..c9d73ce 100644
--- a/setup.py
+++ b/setup.py
@@ -570,7 +570,8 @@ if not getattr(sys, 'getwindowsversion', None):
readme_path = os.path.join(os.path.abspath(os.path.dirname(__file__)),
'README.rst')
-long_desc = open(readme_path, 'r').read()
+with open(readme_path, 'r') as fp:
+ long_desc = fp.read()
setup (name='netifaces',
version=__version__,