summaryrefslogtreecommitdiff
path: root/appveyor.yml
diff options
context:
space:
mode:
authorAlastair Houghton <alastair@alastairs-place.net>2018-02-12 12:12:02 +0000
committerAlastair Houghton <alastair@alastairs-place.net>2018-02-12 12:12:02 +0000
commitfe45705bc587ade090e64916d0dd07de1cc1164f (patch)
treeb240170d44898e9d96178ee8007ac0e55d913437 /appveyor.yml
parente4a372066ba74709a02fbd003935989089e20425 (diff)
downloadnetifaces-git-fe45705bc587ade090e64916d0dd07de1cc1164f.tar.gz
First try at Appveyor.
Diffstat (limited to 'appveyor.yml')
-rw-r--r--appveyor.yml20
1 files changed, 20 insertions, 0 deletions
diff --git a/appveyor.yml b/appveyor.yml
new file mode 100644
index 0000000..0946417
--- /dev/null
+++ b/appveyor.yml
@@ -0,0 +1,20 @@
+environment:
+
+ matrix:
+ - PYTHON: "C:\\Python27"
+ - PYTHON: "C:\\Python36"
+ - PYTHON: "C:\\Python36-x64"
+
+install:
+ - "%PYTHON%\\python.exe -m pip install wheel ."
+
+build: off
+
+test_script:
+ - "%PYTHON%\\python.exe test.py"
+
+after_test:
+ - "%PYTHON%\\python.exe setup.py bdist_wheel"
+
+artifacts:
+ - path: dist\*