summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAlastair Houghton <alastair@alastairs-place.net>2014-05-06 16:21:50 +0100
committerAlastair Houghton <alastair@alastairs-place.net>2014-05-06 16:21:50 +0100
commitf81dae363464ad741a3f826175c0abd5b44379f4 (patch)
tree53dd13f0f1c8602d83acc086e01cbf6da1832f68 /setup.py
parentffe330d57da39d64d5f13168f66a2776ec65143a (diff)
downloadnetifaces-git-f81dae363464ad741a3f826175c0abd5b44379f4.tar.gz
Fix builds on older Linux kernel versions (no NLM_F_DUMP_INTR). Also, test for RTF_IFSCOPE in a more sensible manner.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py33
1 files changed, 1 insertions, 32 deletions
diff --git a/setup.py b/setup.py
index db46b11..a090f9a 100644
--- a/setup.py
+++ b/setup.py
@@ -16,7 +16,7 @@ if sys.version_info[0] == 2:
else:
output = getattr(__builtins__, 'print')
-__version__ = "0.10.2"
+__version__ = "0.10.3"
# Disable hard links, otherwise building distributions fails on OS X
try:
@@ -493,37 +493,6 @@ class my_build_ext(build_ext):
elif results['have_pf_route']:
output('will use routing socket to read routing table')
- # Also check for RTF_IFSCOPE
- output("checking for RTF_IFSCOPE...", end='')
-
- result = results.get('have_rtf_ifscope', None)
- if result is not None:
- cached = '(cached)'
- else:
- cached = ''
-
- testrig = """
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <sys/sysctl.h>
- #include <net/route.h>
-
- int main (void) {
- int scope = RTF_IFSCOPE;
- return 0;
- }
- """
-
- result = self.test_build(testrig)
-
- if result:
- output('yes. %s' % cached)
- self.compiler.define_macro('HAVE_RTF_IFSCOPE', 1)
- else:
- output('no. %s' % cached)
-
- results['have_rtf_ifscope'] = result
-
# Save the results to our config.cache file
myfile = open(cache_file, 'wb')
try: