summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 7 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 7766f26..191f363 100644
--- a/setup.py
+++ b/setup.py
@@ -22,7 +22,7 @@ else:
output = getattr(builtins, 'print', lambda x: True)
-__version__ = "0.10.9"
+__version__ = "0.11.0"
# Disable hard links, otherwise building distributions fails on OS X
try:
@@ -97,7 +97,7 @@ class my_build_ext(build_ext):
result = True
if status != 0:
result = False
-
+
finally:
os.dup2(mystdout, 1)
os.dup2(mystderr, 2)
@@ -123,7 +123,7 @@ class my_build_ext(build_ext):
results = {}
self.conftestidx = 0
-
+
output("checking for getifaddrs...", end='')
result = results.get('have_getifaddrs', None)
@@ -187,7 +187,7 @@ class my_build_ext(build_ext):
sin.sin_family = AF_INET;
sin.sin_port = 0;
sin.sin_addr.s_addr = htonl (INADDR_LOOPBACK);
-
+
ret = getnameinfo ((struct sockaddr *)&sin, sizeof (sin),
buffer, sizeof (buffer),
NULL, 0,
@@ -409,7 +409,7 @@ class my_build_ext(build_ext):
# lengths, because they're in the sa_len field on just about
# everything but Linux.
output("checking which sockaddr_xxx structs are defined...", end='')
-
+
result = results.get('have_sockaddrs', None)
if result is not None:
cached = '(cached)'
@@ -434,7 +434,7 @@ class my_build_ext(build_ext):
#include <net/if.h>
#include <netinet/in.h>
%(includes)s
-
+
int main (void) {
struct sockaddr_%(sockaddr)s sa;
return 0;
@@ -446,7 +446,7 @@ class my_build_ext(build_ext):
if self.test_build(testrig):
result.append(sockaddr)
-
+
if result:
output('%s. %s' % (' '.join(result), cached))
for sockaddr in result: