summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Houghton <alastair@coriolis-systems.com>2017-06-01 14:43:32 +0100
committerAlastair Houghton <alastair@coriolis-systems.com>2017-06-01 14:43:32 +0100
commita379d6f5df83f65e1285e8fc20aad3643d07bcce (patch)
treeaafc6bfca84381961eb0b8ee29060eec8c031051
parent03ecb21b2999486ac569b7a170fc7f7fee28fb2a (diff)
downloadnetifaces-a379d6f5df83f65e1285e8fc20aad3643d07bcce.tar.gz
Bumped version number, updated CHANGELOG.
-rw-r--r--CHANGELOG6
-rw-r--r--README.rst11
-rw-r--r--setup.py2
3 files changed, 14 insertions, 5 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 01fb33f..ca84e12 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,9 @@
+2017-06-01 Version 0.10.6
+
+ * Fixed netmask determination on Windows.
+ * All addresses are now unicode strings on all platforms,
+ regardless of Python version.
+
2016-08-23 Version 0.10.5
* Fixed setup.py in case there's no print (thanks Stavros).
diff --git a/README.rst b/README.rst
index 6f7c0c3..d08c175 100644
--- a/README.rst
+++ b/README.rst
@@ -1,4 +1,4 @@
-netifaces 0.10.5
+netifaces 0.10.6
================
.. image:: https://drone.io/bitbucket.org/al45tair/netifaces/status.png
@@ -24,10 +24,13 @@ This package attempts to solve that problem.
First you need to install it, which you can do by typing::
- tar xvzf netifaces-0.10.5.tar.gz
- cd netifaces-0.10.5
+ tar xvzf netifaces-0.10.6.tar.gz
+ cd netifaces-0.10.6
python setup.py install
+**Note that you will need the relevant developer tools for your platform**,
+as netifaces is written in C and installing this way will compile the extension.
+
Once that's done, you'll need to start Python and do something like the
following::
@@ -164,7 +167,7 @@ wish to contribute a patch, please use BitBucket to send a pull request.
It's an MIT-style license. Here goes:
-Copyright (c) 2007-2016 Alastair Houghton
+Copyright (c) 2007-2017 Alastair Houghton
Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
diff --git a/setup.py b/setup.py
index 0ce3742..80ae7ae 100644
--- a/setup.py
+++ b/setup.py
@@ -22,7 +22,7 @@ else:
output = getattr(builtins, 'print', lambda x: True)
-__version__ = "0.10.5"
+__version__ = "0.10.6"
# Disable hard links, otherwise building distributions fails on OS X
try: