summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJarrod Millman <jarrod.millman@gmail.com>2019-10-16 21:49:53 -0700
committerJarrod Millman <jarrod.millman@gmail.com>2019-10-16 22:14:44 -0700
commit2df70066ecd661aa6ae0a707d10b597c9939c273 (patch)
tree2f7086b207d2f8e547fa31024bd7b2c4a6f7aadd
parent13e62ede8bf986960996a0be8c48a415589faf07 (diff)
downloadnetworkx-2df70066ecd661aa6ae0a707d10b597c9939c273.tar.gz
Drop support for Python 3.5
-rw-r--r--.appveyor.yml8
-rw-r--r--.travis.yml1
-rw-r--r--INSTALL.rst2
-rw-r--r--doc/release/release_dev.rst1
-rw-r--r--examples/advanced/plot_parallel_betweenness.py5
-rw-r--r--networkx/__init__.py4
-rw-r--r--networkx/release.py1
-rw-r--r--setup.py6
8 files changed, 9 insertions, 19 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 0c2987a3..b2bee12c 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -11,16 +11,12 @@ environment:
CACHE_DIR: "%LOCALAPPDATA%\\pip\\Cache"
matrix:
- - PYTHON: "C:\\Python35-x64"
- PYTHON_VERSION: "3.5.3"
- PYTHON_ARCH: "64"
-
- PYTHON: "C:\\Python36-x64"
- PYTHON_VERSION: "3.6.6"
+ PYTHON_VERSION: "3.6.8"
PYTHON_ARCH: "64"
- PYTHON: "C:\\Python37-x64"
- PYTHON_VERSION: "3.7.0"
+ PYTHON_VERSION: "3.7.5"
PYTHON_ARCH: "64"
- PYTHON: "C:\\Python38-x64"
diff --git a/.travis.yml b/.travis.yml
index 86897448..0a550f47 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -63,7 +63,6 @@ matrix:
osx_image: xcode11
language: generic
env: TRAVIS_PYTHON_VERSION=3.8
- - python: 3.5
- python: 3.6
- python: 3.8
- python: pypy3.6-7.1.1
diff --git a/INSTALL.rst b/INSTALL.rst
index df6b5110..b6ddff97 100644
--- a/INSTALL.rst
+++ b/INSTALL.rst
@@ -1,7 +1,7 @@
Install
=======
-NetworkX requires Python 3.5, 3.6, 3.7, or 3.8. If you do not already
+NetworkX requires Python 3.6, 3.7, or 3.8. If you do not already
have a Python environment configured on your computer, please see the
instructions for installing the full `scientific Python stack
<https://scipy.org/install.html>`_.
diff --git a/doc/release/release_dev.rst b/doc/release/release_dev.rst
index d654a4df..5fa1de57 100644
--- a/doc/release/release_dev.rst
+++ b/doc/release/release_dev.rst
@@ -17,6 +17,7 @@ Highlights
This release is the result of 6 months of work with over X pull requests by
X contributors. Highlights include:
+- Dropped support for Python 3.5.
Improvements
------------
diff --git a/examples/advanced/plot_parallel_betweenness.py b/examples/advanced/plot_parallel_betweenness.py
index 897656f4..ae098477 100644
--- a/examples/advanced/plot_parallel_betweenness.py
+++ b/examples/advanced/plot_parallel_betweenness.py
@@ -10,11 +10,6 @@ The function betweenness centrality accepts a bunch of nodes and computes
the contribution of those nodes to the betweenness centrality of the whole
network. Here we divide the network in chunks of nodes and we compute their
contribution to the betweenness centrality of the whole network.
-
-This doesn't work in python2.7.13. It does work in 3.6, 3.5, 3.4, and 3.3.
-
-It may be related to this:
-https://stackoverflow.com/questions/1816958/cant-pickle-type-instancemethod-when-using-multiprocessing-pool-map
"""
from multiprocessing import Pool
diff --git a/networkx/__init__.py b/networkx/__init__.py
index 61f88774..61a1a4e2 100644
--- a/networkx/__init__.py
+++ b/networkx/__init__.py
@@ -63,8 +63,8 @@ Released under the 3-Clause BSD license::
#
import sys
-if sys.version_info[:2] < (3, 5):
- m = "Python 3.5 or later is required for NetworkX (%d.%d detected)."
+if sys.version_info[:2] < (3, 6):
+ m = "Python 3.6 or later is required for NetworkX (%d.%d detected)."
raise ImportError(m % sys.version_info[:2])
del sys
diff --git a/networkx/release.py b/networkx/release.py
index 309e8ae8..c047ca78 100644
--- a/networkx/release.py
+++ b/networkx/release.py
@@ -206,7 +206,6 @@ classifiers = [
'License :: OSI Approved :: BSD License',
'Operating System :: OS Independent',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
diff --git a/setup.py b/setup.py
index 03bfd53a..0aa27d05 100644
--- a/setup.py
+++ b/setup.py
@@ -19,8 +19,8 @@ if sys.argv[-1] == 'setup.py':
print("To install, run 'python setup.py install'")
print()
-if sys.version_info[:2] < (3, 5):
- error = """NetworkX 2.3+ requires Python 3.5 or later (%d.%d detected).
+if sys.version_info[:2] < (3, 6):
+ error = """NetworkX 2.5+ requires Python 3.6 or later (%d.%d detected).
For Python 2.7, please install version 2.2 using:
@@ -162,6 +162,6 @@ if __name__ == "__main__":
package_data=package_data,
install_requires=install_requires,
extras_require=extras_require,
- python_requires='>=3.5',
+ python_requires='>=3.6',
zip_safe=False
)