summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJarrod Millman <jarrod.millman@gmail.com>2020-12-17 11:02:12 -0800
committerGitHub <noreply@github.com>2020-12-17 11:02:12 -0800
commit5618142c87696c3adfe6490eec65c10098e320c1 (patch)
treef333b0ca2a28f63462399a4bd567837d5b345af6
parent0c3adb519c5d1809a6541fab6868f81ece3cd4f0 (diff)
downloadnetworkx-5618142c87696c3adfe6490eec65c10098e320c1.tar.gz
Drop Py3.6 support per NEP 29 (#4469)
-rw-r--r--.appveyor.yml4
-rw-r--r--.github/workflows/test.yml6
-rw-r--r--INSTALL.rst2
-rw-r--r--doc/release/release_dev.rst3
-rw-r--r--networkx/__init__.py4
-rw-r--r--networkx/release.py1
-rw-r--r--setup.py6
7 files changed, 11 insertions, 15 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index a0ef5629..2029d67b 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -11,10 +11,6 @@ environment:
CACHE_DIR: "%LOCALAPPDATA%\\pip\\Cache"
matrix:
- - PYTHON: "C:\\Python36-x64"
- PYTHON_VERSION: "3.6"
- PYTHON_ARCH: "64"
-
- PYTHON: "C:\\Python37-x64"
PYTHON_VERSION: "3.7"
PYTHON_ARCH: "64"
diff --git a/.github/workflows/test.yml b/.github/workflows/test.yml
index 2f9b3ab0..1a3772ab 100644
--- a/.github/workflows/test.yml
+++ b/.github/workflows/test.yml
@@ -13,7 +13,7 @@ jobs:
strategy:
matrix:
os: [ubuntu, macos]
- python-version: [3.6, 3.7, 3.8, 3.9, pypy3]
+ python-version: [3.7, 3.8, 3.9, pypy-3.7]
steps:
- uses: actions/checkout@v2
- name: Set up Python ${{ matrix.python-version }}
@@ -43,7 +43,7 @@ jobs:
strategy:
matrix:
os: [ubuntu-20.04, macos-latest]
- python-version: [3.6, 3.7, 3.8, 3.9]
+ python-version: [3.7, 3.8, 3.9]
steps:
- uses: actions/checkout@v2
- name: Set up Python ${{ matrix.python-version }}
@@ -79,7 +79,7 @@ jobs:
strategy:
matrix:
os: [ubuntu, macos]
- python-version: [3.6, 3.7, 3.8, 3.9]
+ python-version: [3.7, 3.8, 3.9]
steps:
- uses: actions/checkout@v2
- name: Set up Python ${{ matrix.python-version }}
diff --git a/INSTALL.rst b/INSTALL.rst
index 3fbee695..de6fae39 100644
--- a/INSTALL.rst
+++ b/INSTALL.rst
@@ -1,7 +1,7 @@
Install
=======
-NetworkX requires Python 3.6, 3.7, 3.8, or 3.9. If you do not already
+NetworkX requires Python 3.7, 3.8, or 3.9. If you do not already
have a Python environment configured on your computer, please see the
instructions for installing the full `scientific Python stack
<https://scipy.org/install.html>`_.
diff --git a/doc/release/release_dev.rst b/doc/release/release_dev.rst
index 8adf5300..47c17a2a 100644
--- a/doc/release/release_dev.rst
+++ b/doc/release/release_dev.rst
@@ -17,13 +17,14 @@ Highlights
This release is the result of X of work with over X pull requests by
X contributors. Highlights include:
+- Dropped support for Python 3.6.
- NumPy, SciPy, Matplotlib, and pandas are now default requirements.
Improvements
------------
- [`#4319 <https://github.com/networkx/networkx/pull/4319>`_]
-pagerank uses scipy by default now.
+ pagerank uses scipy by default now.
- [`#4317 <https://github.com/networkx/networkx/pull/4317>`_]
New ``source`` argument to ``has_eulerian_path`` to look for path starting at
source.
diff --git a/networkx/__init__.py b/networkx/__init__.py
index 26afbc67..9d3e57cb 100644
--- a/networkx/__init__.py
+++ b/networkx/__init__.py
@@ -10,8 +10,8 @@ See https://networkx.org for complete documentation.
import sys
-if sys.version_info[:2] < (3, 6):
- m = "Python 3.6 or later is required for NetworkX (%d.%d detected)."
+if sys.version_info[:2] < (3, 7):
+ m = "Python 3.7 or later is required for NetworkX (%d.%d detected)."
raise ImportError(m % sys.version_info[:2])
del sys
diff --git a/networkx/release.py b/networkx/release.py
index 30f20ea2..94b3a42a 100644
--- a/networkx/release.py
+++ b/networkx/release.py
@@ -216,7 +216,6 @@ classifiers = [
"License :: OSI Approved :: BSD License",
"Operating System :: OS Independent",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
diff --git a/setup.py b/setup.py
index 3c3d86c5..73514221 100644
--- a/setup.py
+++ b/setup.py
@@ -18,9 +18,9 @@ if sys.argv[-1] == "setup.py":
print("To install, run 'python setup.py install'")
print()
-if sys.version_info[:2] < (3, 6):
+if sys.version_info[:2] < (3, 7):
error = (
- "NetworkX 2.5+ requires Python 3.6 or later (%d.%d detected). \n"
+ "NetworkX 2.6+ requires Python 3.7 or later (%d.%d detected). \n"
"For Python 2.7, please install version 2.2 using: \n"
"$ pip install 'networkx==2.2'" % sys.version_info[:2]
)
@@ -162,6 +162,6 @@ if __name__ == "__main__":
package_data=package_data,
install_requires=install_requires,
extras_require=extras_require,
- python_requires=">=3.6",
+ python_requires=">=3.7",
zip_safe=False,
)