summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJarrod Millman <jarrod.millman@gmail.com>2022-10-08 18:49:55 -0700
committerGitHub <noreply@github.com>2022-10-08 18:49:55 -0700
commit9279be80efe674f44380a15d239ed9784fb70f9d (patch)
tree24151fffb2135c95bd6ddfbe47aae7e3b48924e7
parent341e2bc831e122899381e2bee8644af5d7dacb2a (diff)
downloadnetworkx-9279be80efe674f44380a15d239ed9784fb70f9d.tar.gz
Support Python 3.11 (#6023)
-rw-r--r--.github/workflows/test.yml4
-rw-r--r--setup.py1
2 files changed, 3 insertions, 2 deletions
diff --git a/.github/workflows/test.yml b/.github/workflows/test.yml
index 0f1d2590..a2c2f2d4 100644
--- a/.github/workflows/test.yml
+++ b/.github/workflows/test.yml
@@ -12,7 +12,7 @@ jobs:
strategy:
matrix:
os: [ubuntu, macos, windows]
- python-version: ["pypy-3.8", "3.11-dev"]
+ python-version: ["pypy-3.8"]
steps:
- uses: actions/checkout@v3
- name: Set up Python ${{ matrix.python-version }}
@@ -36,7 +36,7 @@ jobs:
strategy:
matrix:
os: [ubuntu, macos, windows]
- python-version: ["3.8", "3.9", "3.10"]
+ python-version: ["3.8", "3.9", "3.10", "3.11-dev"]
steps:
- uses: actions/checkout@v3
- name: Set up Python ${{ matrix.python-version }}
diff --git a/setup.py b/setup.py
index 02813bdf..43587fb1 100644
--- a/setup.py
+++ b/setup.py
@@ -48,6 +48,7 @@ classifiers = [
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
"Programming Language :: Python :: 3 :: Only",
"Topic :: Software Development :: Libraries :: Python Modules",
"Topic :: Scientific/Engineering :: Bio-Informatics",