summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJarrod Millman <jarrod.millman@gmail.com>2021-11-22 17:36:35 -0800
committerGitHub <noreply@github.com>2021-11-22 17:36:35 -0800
commit9b26842f3a7d5dc0055f70e839e3a891eb1d3dbb (patch)
tree16d0ee523cc75ac03b8cdd49035d00ee18f860c6
parent3858c531213b88564b3390f34eb9a9c2c0ae5b0d (diff)
downloadnetworkx-9b26842f3a7d5dc0055f70e839e3a891eb1d3dbb.tar.gz
Test on Python 3.10 (#5185)
Co-authored-by: Ross Barnowski <rossbar@berkeley.edu>
-rw-r--r--INSTALL.rst2
-rw-r--r--requirements/default.txt2
-rw-r--r--setup.py1
3 files changed, 3 insertions, 2 deletions
diff --git a/INSTALL.rst b/INSTALL.rst
index 6a8b6f78..792c099b 100644
--- a/INSTALL.rst
+++ b/INSTALL.rst
@@ -1,7 +1,7 @@
Install
=======
-NetworkX requires Python 3.8 or 3.9. If you do not already
+NetworkX requires Python 3.8, 3.9, or 3.10. If you do not already
have a Python environment configured on your computer, please see the
instructions for installing the full `scientific Python stack
<https://scipy.org/install.html>`_.
diff --git a/requirements/default.txt b/requirements/default.txt
index 15b8c4e2..544f4e1a 100644
--- a/requirements/default.txt
+++ b/requirements/default.txt
@@ -1,4 +1,4 @@
numpy>=1.19
scipy>=1.6.2
-matplotlib>=3.3; python_version<'3.10'
+matplotlib>=3.4
pandas>=1.2
diff --git a/setup.py b/setup.py
index 74a8ce86..73b1eda0 100644
--- a/setup.py
+++ b/setup.py
@@ -47,6 +47,7 @@ classifiers = [
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
"Programming Language :: Python :: 3 :: Only",
"Topic :: Software Development :: Libraries :: Python Modules",
"Topic :: Scientific/Engineering :: Bio-Informatics",