summaryrefslogtreecommitdiff
path: root/ruff.toml
diff options
context:
space:
mode:
authorMridul Seth <seth.mridul@gmail.com>2023-02-26 02:52:51 +0100
committerGitHub <noreply@github.com>2023-02-25 17:52:51 -0800
commit045c46c2ef652b8793bfd36ce31400c693b54438 (patch)
tree0947802ebdbbfee6cdf04a3be7dc1e24ff839020 /ruff.toml
parent0b0a5fc5c512c2cbacd374860e47742e48a8dcfe (diff)
downloadnetworkx-045c46c2ef652b8793bfd36ce31400c693b54438.tar.gz
Start using ruff for pyupgrade and isort (#6441)
Diffstat (limited to 'ruff.toml')
-rw-r--r--ruff.toml11
1 files changed, 11 insertions, 0 deletions
diff --git a/ruff.toml b/ruff.toml
index c9268b24..e0b0e30d 100644
--- a/ruff.toml
+++ b/ruff.toml
@@ -1,4 +1,6 @@
select = [
+ "I", # isort
+ "UP", # pyupgrade
"C4", # flake8-comprehensions
"E713", # use 'key not in list'
"PIE", # flake8-pie
@@ -11,3 +13,12 @@ select = [
"SIM118", # use 'key in dict'
"SIM2", # simplify boolean comparisons
]
+
+target-version = "py38"
+
+[per-file-ignores]
+"__init__.py" = ["I"]
+"setup.py" = ["I"]
+"examples/*.py" = ["I"]
+"doc/*.py" = ["I"]
+"tools/*.py" = ["I"]