summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorYuto Yamaguchi <yamaguchiyuto@users.noreply.github.com>2018-01-28 22:12:28 +0900
committerDan Schult <dschult@colgate.edu>2018-01-28 08:12:28 -0500
commit39866aa66e8ae7999348f35d75616b76a9d453ba (patch)
treedece099c0e780b51fc4c94a6238283e01add3607 /setup.py
parentb22da6106736394fa7624c016c8734c960bf0699 (diff)
downloadnetworkx-39866aa66e8ae7999348f35d75616b76a9d453ba.tar.gz
Implement a module for node classification (#2848)
* Implement a module for node classification * Fix tests * Put helper functions inside the public function. * Rename modules * Fix examples * Try imports * Add a doc for node classification * Add one test case * Add skip annotation. * Follow PEP8 * Follow PEP8 in test code * Fix doctest violation
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 02ee9cd9..dfe9cf52 100644
--- a/setup.py
+++ b/setup.py
@@ -34,6 +34,7 @@ packages = ["networkx",
"networkx.algorithms",
"networkx.algorithms.assortativity",
"networkx.algorithms.bipartite",
+ "networkx.algorithms.node_classification",
"networkx.algorithms.centrality",
"networkx.algorithms.community",
"networkx.algorithms.components",
@@ -85,6 +86,7 @@ package_data = {
'networkx.algorithms': ['tests/*.py'],
'networkx.algorithms.assortativity': ['tests/*.py'],
'networkx.algorithms.bipartite': ['tests/*.py'],
+ 'networkx.algorithms.node_classification': ['tests/*.py'],
'networkx.algorithms.centrality': ['tests/*.py'],
'networkx.algorithms.community': ['tests/*.py'],
'networkx.algorithms.components': ['tests/*.py'],