summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--INSTALL.rst12
-rw-r--r--doc/news.rst3
-rw-r--r--setup.py4
3 files changed, 10 insertions, 9 deletions
diff --git a/INSTALL.rst b/INSTALL.rst
index ee28deee..e8a6f48c 100644
--- a/INSTALL.rst
+++ b/INSTALL.rst
@@ -1,7 +1,7 @@
Install
=======
-NetworkX requires Python 2.7, 3.4, 3.5, or 3.6. If you do not already
+NetworkX requires Python 2.7, 3.5, 3.6, or 3.7. If you do not already
have a Python environment configured on your computer, please see the
instructions for installing the full `scientific Python stack
<https://scipy.org/install.html>`_.
@@ -87,17 +87,17 @@ Optional packages
The following optional packages provide additional functionality.
-- `NumPy <http://www.numpy.org/>`_ (>= 1.12.0) provides matrix representation of
+- `NumPy <http://www.numpy.org/>`_ (>= 1.15.0) provides matrix representation of
graphs and is used in some graph algorithms for high-performance matrix
computations.
-- `SciPy <http://scipy.org/>`_ (>= 0.19.0) provides sparse matrix representation
+- `SciPy <http://scipy.org/>`_ (>= 1.1.0) provides sparse matrix representation
of graphs and many numerical scientific tools.
-- `pandas <http://pandas.pydata.org/>`_ (>= 0.20.0) provides a DataFrame, which
+- `pandas <http://pandas.pydata.org/>`_ (>= 0.23.3) provides a DataFrame, which
is a tabular data structure with labeled axes.
-- `Matplotlib <http://matplotlib.org/>`_ (>= 2.0.2) provides flexible drawing of
+- `Matplotlib <http://matplotlib.org/>`_ (>= 2.2.2) provides flexible drawing of
graphs.
- `PyGraphviz <http://pygraphviz.github.io/>`_ and
- `pydot <https://github.com/erocarrera/pydot>`_ (>= 1.2.3) provide graph drawing
+ `pydot <https://github.com/erocarrera/pydot>`_ (>= 1.2.4) provide graph drawing
and graph layout algorithms via `GraphViz <http://graphviz.org/>`_.
- `PyYAML <http://pyyaml.org/>`_ provides YAML format reading and writing.
- `gdal <http://www.gdal.org/>`_ provides shapefile format reading and writing.
diff --git a/doc/news.rst b/doc/news.rst
index a0fe28af..54d3700a 100644
--- a/doc/news.rst
+++ b/doc/news.rst
@@ -8,6 +8,8 @@ NetworkX 2.2
------------
Release date: TBD
+Supports Python 2.7, 3.5, 3.6 and 3.7.
+
Release notes
~~~~~~~~~~~~~
@@ -20,7 +22,6 @@ Release date: 22 January 2018
Supports Python 2.7, 3.4, 3.5, and 3.6.
-
Release notes
~~~~~~~~~~~~~
diff --git a/setup.py b/setup.py
index f18d142f..bbd71ba0 100644
--- a/setup.py
+++ b/setup.py
@@ -116,7 +116,7 @@ package_data = {
'networkx.utils': ['tests/*.py']
}
-install_requires = ['decorator>=4.1.0']
+install_requires = ['decorator>=4.3.0']
extras_require = {'all': ['numpy', 'scipy', 'pandas', 'matplotlib',
'pygraphviz', 'pydot', 'pyyaml', 'gdal', 'lxml',
'nose'],
@@ -155,6 +155,6 @@ if __name__ == "__main__":
install_requires=install_requires,
extras_require=extras_require,
test_suite='nose.collector',
- tests_require=['nose>=0.10.1'],
+ tests_require=['nose>=1.3.7'],
zip_safe=False
)