summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--INSTALL.rst9
-rw-r--r--requirements/default.txt2
-rw-r--r--requirements/extras.txt4
-rw-r--r--setup.py4
4 files changed, 10 insertions, 9 deletions
diff --git a/INSTALL.rst b/INSTALL.rst
index 5d4cd3f0..d8284bb0 100644
--- a/INSTALL.rst
+++ b/INSTALL.rst
@@ -87,20 +87,21 @@ Optional packages
The following optional packages provide additional functionality.
-- `NumPy <http://www.numpy.org/>`_ (>= 1.6) provides matrix representation of
+- `NumPy <http://www.numpy.org/>`_ (>= 1.12.0) provides matrix representation of
graphs and is used in some graph algorithms for high-performance matrix
computations.
-- `SciPy <http://scipy.org/>`_ (>= 0.10) provides sparse matrix representation
+- `SciPy <http://scipy.org/>`_ (>= 0.19.0) provides sparse matrix representation
of graphs and many numerical scientific tools.
-- `pandas <http://pandas.pydata.org/>`_ (>= 0.8) provides a DataFrame, which
+- `pandas <http://pandas.pydata.org/>`_ (>= 0.20.0) provides a DataFrame, which
is a tabular data structure with labeled axes.
-- `Matplotlib <http://matplotlib.org/>`_ (>= 1.1) provides flexible drawing of
+- `Matplotlib <http://matplotlib.org/>`_ (>= 2.0.2) provides flexible drawing of
graphs.
- `PyGraphviz <http://pygraphviz.github.io/>`_ and
`pydot <https://github.com/erocarrera/pydot>`_ (>= 1.2.3) provide graph drawing
and graph layout algorithms via `GraphViz <http://graphviz.org/>`_.
- `PyYAML <http://pyyaml.org/>`_ provides YAML format reading and writing.
- `gdal <http://www.gdal.org/>`_ provides shapefile format reading and writing.
+- `lxml <http://lxml.de/>`_ used for GraphML XML format.
To install ``networkx`` and all optional packages, do::
diff --git a/requirements/default.txt b/requirements/default.txt
index 14764baf..d4d2edf6 100644
--- a/requirements/default.txt
+++ b/requirements/default.txt
@@ -1 +1 @@
-decorator>=4.1.2
+decorator>=4.1.0
diff --git a/requirements/extras.txt b/requirements/extras.txt
index 217ca56a..a0b1fcea 100644
--- a/requirements/extras.txt
+++ b/requirements/extras.txt
@@ -1,9 +1,9 @@
numpy>=1.12.0
-scipy>=0.18.1
+scipy>=0.19.0
pandas>=0.20.0
matplotlib>=2.0.2
pygraphviz>=1.3.1
pydot>=1.2.3
pyyaml>=3.12
gdal==1.10.0
-lxml
+lxml>=3.7.3
diff --git a/setup.py b/setup.py
index 7d59315b..02ee9cd9 100644
--- a/setup.py
+++ b/setup.py
@@ -108,9 +108,9 @@ package_data = {
'networkx.utils': ['tests/*.py']
}
-install_requires = ['decorator>=3.4.0']
+install_requires = ['decorator>=4.1.0']
extras_require = {'all': ['numpy', 'scipy', 'pandas', 'matplotlib',
- 'pygraphviz', 'pydot', 'pyyaml', 'gdal']}
+ 'pygraphviz', 'pydot', 'pyyaml', 'gdal', 'lxml']}
if __name__ == "__main__":