summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason Pellerin <jpellerin@gmail.com>2007-04-24 04:27:31 +0000
committerJason Pellerin <jpellerin@gmail.com>2007-04-24 04:27:31 +0000
commit984bf51c327831a5c5a6807523be03ae56d8482a (patch)
tree3fa2f1f43084c0cfc9cf23b59789043be104c7b7 /setup.py
parentccb4cd753ac7b9af614e053de2729386e49a455f (diff)
downloadnose-984bf51c327831a5c5a6807523be03ae56d8482a.tar.gz
MERGE trunk r10:r196 into 0.10-dev branch: some tests now fail
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py39
1 files changed, 23 insertions, 16 deletions
diff --git a/setup.py b/setup.py
index 35164e1..3f54bc2 100644
--- a/setup.py
+++ b/setup.py
@@ -27,28 +27,35 @@ setup(
author = 'Jason Pellerin',
author_email = 'jpellerin+nose@gmail.com',
description = ('A unittest extension offering automatic test suite '
- 'discovery, simplified test authoring, and output capture'),
- long_description = ('nose provides an alternate test discovery and '
- 'running process for unittest, one that is intended '
- 'to mimic the behavior of py.test as much as is '
- 'reasonably possible without resorting to magic. '
- 'By default, nose will run tests in files or '
- 'directories under the current working directory '
- 'whose names include "test". nose also supports '
- 'doctest tests and may optionally provide a '
- 'test coverage report.\n\n'
- 'If you have recently reported a bug marked as fixed, '
- 'or have a craving for the very latest, you may want '
- 'the development version instead: '
- 'http://svn.nose.python-hosting.com/trunk#egg=nose-dev'
- ),
+ 'discovery and easy test authoring'),
+ long_description = \
+ """nose extends the test loading and running features of unittest, making
+ it easier to write, find and run tests.
+
+ By default, nose will run tests in files or directories under the current
+ working directory whose names include "test" or "Test" at a word boundary
+ (like "test_this" or "functional_test" or "TestClass" but not
+ "libtest"). Test output is similar to that of unittest, but also includes
+ captured stdout output from failing tests, for easy print-style debugging.
+
+ These features, and many more, are customizable through the use of
+ plugins. Plugins included with nose provide support for doctest, code
+ coverage and profiling, and flexible attribute-based test
+ selection. More information about writing plugins may be found on the
+ wiki, here: http://code.google.com/p/python-nose/wiki/WritingPlugins.
+
+ If you have recently reported a bug marked as fixed, or have a craving for
+ the very latest, you may want the development version instead:
+ http://python-nose.googlecode.com/svn/trunk#egg=nose-dev
+ """,
license = 'GNU LGPL',
keywords = 'test unittest doctest automatic discovery',
url = 'http://somethingaboutorange.com/mrl/projects/nose/',
download_url = \
'http://somethingaboutorange.com/mrl/projects/nose/nose-%s.tar.gz' \
% VERSION,
- package_data = { '': [ '*.txt' ] },
+ data_files = [('man/man1', ['nosetests.1'])],
+ package_data = {'': ['*.txt']},
classifiers = [
'Development Status :: 4 - Beta',
'Intended Audience :: Developers',