summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG7
-rw-r--r--doc/conf.py2
-rw-r--r--functional_tests/doc_tests/test_coverage_html/coverage_html.rst8
-rw-r--r--nose/__init__.py2
-rw-r--r--nose/plugins/cover.py1
-rw-r--r--nosetests.12
-rw-r--r--setup.py2
7 files changed, 18 insertions, 6 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 2e5da90..a736d3d 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,8 @@
+1.1.2
+
+- Fixed regression where the .coverage file was not saved (#439).
+ Patch by Timothée Peignier.
+
1.1.1
- Fixed missing nose.sphinx module in source distribution (#436).
@@ -11,7 +16,7 @@
- Lots of improvements to the attrib plugin by Bobby Impollonia (#412, #411,
#324 and #381)
- Code coverage plugin now uses native HTML generation when coverage 3 is
- installed (#264). Thanks to Timothee Peignier for the patch.
+ installed (#264). Thanks to Timothée Peignier for the patch.
- Xunit plugin now shows test run time in fractions of a second (#317)
- @attr (from nose.plugins.attrib) can now be used as a class decorator (#292)
- Fixes Xunit plugin to handle non-UTF8 characters (#395)
diff --git a/doc/conf.py b/doc/conf.py
index bc4fcc4..3fb4326 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -57,7 +57,7 @@ copyright = u'2009, Jason Pellerin'
# The short X.Y version.
version = '1.1'
# The full version, including alpha/beta/rc tags.
-release = '1.1.1'
+release = '1.1.2'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/functional_tests/doc_tests/test_coverage_html/coverage_html.rst b/functional_tests/doc_tests/test_coverage_html/coverage_html.rst
index 89c4bd5..95f9e8a 100644
--- a/functional_tests/doc_tests/test_coverage_html/coverage_html.rst
+++ b/functional_tests/doc_tests/test_coverage_html/coverage_html.rst
@@ -14,12 +14,16 @@ code coverage, the coverage plugin supports basic HTML coverage output.
>>> import os
>>> support = os.path.join(os.path.dirname(__file__), 'support')
>>> cover_html_dir = os.path.join(support, 'cover')
+ >>> cover_file = os.path.join(os.getcwd(), '.coverage')
+ >>> if os.path.exists(cover_file):
+ ... os.unlink(cover_file)
+ ...
The console coverage output is printed, as normal.
- >>> cover_html_dir = os.path.join(support, 'cover')
>>> from nose.plugins.cover import Coverage
+ >>> cover_html_dir = os.path.join(support, 'cover')
>>> run(argv=[__file__, '-v', '--with-coverage', '--cover-package=blah',
... '--cover-html', '--cover-html-dir=' + cover_html_dir,
... support, ],
@@ -43,6 +47,8 @@ covered and which are not. There is an example of this HTML output in the
`coverage.py`_ docs.
.. hide this from the actual documentation:
+ >>> os.path.exists(cover_file)
+ True
>>> os.path.exists(os.path.join(cover_html_dir, 'index.html'))
True
>>> os.path.exists(os.path.join(cover_html_dir, 'blah.html'))
diff --git a/nose/__init__.py b/nose/__init__.py
index 7152f23..1ebf76d 100644
--- a/nose/__init__.py
+++ b/nose/__init__.py
@@ -4,7 +4,7 @@ from nose.exc import SkipTest, DeprecatedTest
from nose.tools import with_setup
__author__ = 'Jason Pellerin'
-__versioninfo__ = (1, 1, 1)
+__versioninfo__ = (1, 1, 2)
__version__ = '.'.join(map(str, __versioninfo__))
__all__ = [
diff --git a/nose/plugins/cover.py b/nose/plugins/cover.py
index 259bf0c..f10b198 100644
--- a/nose/plugins/cover.py
+++ b/nose/plugins/cover.py
@@ -164,6 +164,7 @@ class Coverage(Plugin):
"""
log.debug("Coverage report")
self.coverInstance.stop()
+ self.coverInstance.save()
modules = [ module
for name, module in sys.modules.items()
if self.wantModuleCoverage(name, module) ]
diff --git a/nosetests.1 b/nosetests.1
index eb93714..c8fe5d5 100644
--- a/nosetests.1
+++ b/nosetests.1
@@ -476,5 +476,5 @@ jpellerin+nose@gmail.com
.SH COPYRIGHT
LGPL
-.\" Generated by docutils manpage writer on 2011-07-27 17:21.
+.\" Generated by docutils manpage writer on 2011-07-30 18:43.
.\"
diff --git a/setup.py b/setup.py
index 86c3117..d8615c3 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,7 @@
import sys
import os
-VERSION = '1.1.1'
+VERSION = '1.1.2'
py_vers_tag = '-%s.%s' % sys.version_info[:2]
test_dirs = ['functional_tests', 'unit_tests', os.path.join('doc','doc_tests'), 'nose']