summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--DEVELOPERS.txt33
-rwxr-xr-xrun_tests.sh3
-rw-r--r--selftest.py3
-rwxr-xr-xtest.sh34
4 files changed, 37 insertions, 36 deletions
diff --git a/DEVELOPERS.txt b/DEVELOPERS.txt
new file mode 100644
index 0000000..ebd74a3
--- /dev/null
+++ b/DEVELOPERS.txt
@@ -0,0 +1,33 @@
+Hello and welcome! Thanks for taking the time to work on Nose.
+
+Run the Test Suite
+==================
+
+Install `tox`_ so that it's accessible on $PATH somehow. The cd into the source and type::
+
+ $ tox
+
+.. _`tox`: http://codespeak.net/tox/
+
+That will try to run tests in all of the Python interpreters that Nose
+supports. If you don't have one of those versions installed please ask for
+assistance so you don't develop an incompatible feature.
+
+For a quick spot check of the tests you can test against a specific version
+like this::
+
+ $ tox -e py26
+
+All Features Must Have Tests
+============================
+
+Well, duh. If you get stuck on this just ask. There are lots of ways to
+make quick regression tests out of nose based suites.
+
+Code Style
+==========
+
+Please follow `PEP8`_ for all contributed code. Specifically, please keep
+the window width to 80 chars and follow the PEP8 formatting style.
+
+.. _`PEP8`: http://www.python.org/dev/peps/pep-0008/
diff --git a/run_tests.sh b/run_tests.sh
index 59f18f5..c0df6fb 100755
--- a/run_tests.sh
+++ b/run_tests.sh
@@ -4,5 +4,6 @@ if [ -e "`which tox`" ]; then
tox $@
else
echo "**** install tox globally to test all Pythons at once http://codespeak.net/tox/"
- exec ./selftest.py $@
+ python setup.py egg_info
+ python selftest.py $@
fi \ No newline at end of file
diff --git a/selftest.py b/selftest.py
index af91642..b07d71f 100644
--- a/selftest.py
+++ b/selftest.py
@@ -48,7 +48,8 @@ if __name__ == "__main__":
import pkg_resources
env = pkg_resources.Environment(search_path=lib_dirs)
distributions = env["nose"]
- assert len(distributions) == 1
+ assert len(distributions) == 1, (
+ "Incorrect usage of selftest.py; please see DEVELOPERS.txt")
dist = distributions[0]
dist.activate()
except ImportError:
diff --git a/test.sh b/test.sh
deleted file mode 100755
index 5fa6fa7..0000000
--- a/test.sh
+++ /dev/null
@@ -1,34 +0,0 @@
-#!/bin/sh
-
-echo "python 2.3..."
-python2.3 selftest.py
-
-echo
-echo "python 2.4..."
-python2.4 selftest.py
-
-echo
-echo "python 2.5..."
-python2.5 selftest.py
-
-echo
-echo "python 2.6..."
-python2.6 selftest.py
-
-echo
-echo "python 2.7..."
-python2.7 selftest.py
-
-if [ "${JYTHON}x" != "x" ]
-then
- echo
- echo "jython..."
- $JYTHON selftest.py
-else
- echo
- echo '$JYTHON not set'
- echo 'set $JYTHON to run selftest under jython'
- echo 'example: '
- echo " export JYTHON='java -Dpython.home=<path>/dist/ -jar <path>/dist/jython.jar'"
- echo 'see http://wiki.python.org/jython/JythonDeveloperGuide'
-fi