summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharles Harris <charlesr.harris@gmail.com>2017-11-30 12:06:21 -0700
committerGitHub <noreply@github.com>2017-11-30 12:06:21 -0700
commita3bb8f83de6f0fe3d0dfa14b9bfe1889f9b45652 (patch)
tree19255bef6948302657649cd9fca188cf42435984
parent10d731b0b30225d137be029bc57e87547a0fdb84 (diff)
parent2585cf76013d6cfa61e99e859ca3c05de379a97e (diff)
downloadnumpy-maintenance/1.13.x.tar.gz
Merge pull request #10137 from charris/add-license-to-installmaintenance/1.13.x
BLD: Add license file to NumPy wheels.
-rw-r--r--MANIFEST.in3
-rwxr-xr-xsetup.py7
2 files changed, 6 insertions, 4 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 4e5206b94..3d3e47f45 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -11,6 +11,7 @@ recursive-include numpy/random/mtrand *.pyx *.pxd
# Add build support that should go in sdist, but not go in bdist/be installed
recursive-include numpy/_build_utils *
recursive-include numpy/linalg/lapack_lite *.c *.h
+include tox.ini
# Add sdist files whose use depends on local configuration.
include numpy/core/src/multiarray/cblasfuncs.c
include numpy/core/src/multiarray/python_xerbla.c
@@ -27,4 +28,4 @@ recursive-include tools/swig *
recursive-include doc/scipy-sphinx-theme *
recursive-include doc/f2py *
-global-exclude *.pyc *.pyo *.pyd
+global-exclude *.pyc *.pyo *.pyd *.swp *.bak *~
diff --git a/setup.py b/setup.py
index ed8b457bf..d0749985e 100755
--- a/setup.py
+++ b/setup.py
@@ -81,7 +81,7 @@ def git_version():
env['LANGUAGE'] = 'C'
env['LANG'] = 'C'
env['LC_ALL'] = 'C'
- out = subprocess.Popen(cmd, stdout = subprocess.PIPE, env=env).communicate()[0]
+ out = subprocess.Popen(cmd, stdout=subprocess.PIPE, env=env).communicate()[0]
return out
try:
@@ -147,8 +147,8 @@ if not release:
a = open(filename, 'w')
try:
a.write(cnt % {'version': VERSION,
- 'full_version' : FULLVERSION,
- 'git_revision' : GIT_REVISION,
+ 'full_version': FULLVERSION,
+ 'git_revision': GIT_REVISION,
'isrelease': str(ISRELEASED)})
finally:
a.close()
@@ -164,6 +164,7 @@ def configuration(parent_package='',top_path=None):
quiet=True)
config.add_subpackage('numpy')
+ config.add_data_files(('numpy', 'LICENSE.txt'))
config.get_version('numpy/version.py') # sets config.version