summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Huot <JonathanHuot@users.noreply.github.com>2022-01-29 23:12:02 +0100
committerGitHub <noreply@github.com>2022-01-29 23:12:02 +0100
commitccf9189bd5a60ad490351c005db042c9788ac441 (patch)
tree8abea2388258f9f80a12e5e305de598b5c656f45
parentc45943f89c98a8f8f185128eddca0e359311a6ad (diff)
parent112404878bdc8b492764e133c388afb978392e09 (diff)
downloadoauthlib-ccf9189bd5a60ad490351c005db042c9788ac441.tar.gz
Merge pull request #800 from oauthlib/3.2.0-dev
Changelog 3.2.0
-rw-r--r--.travis.yml4
-rw-r--r--AUTHORS19
-rw-r--r--CHANGELOG.rst27
-rw-r--r--docs/feature_matrix.rst21
-rw-r--r--oauthlib/__init__.py2
-rw-r--r--oauthlib/oauth2/rfc8628/clients/device.py2
-rw-r--r--tox.ini4
7 files changed, 55 insertions, 24 deletions
diff --git a/.travis.yml b/.travis.yml
index 6b195b6..b2dad7a 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -8,9 +8,9 @@ jobs:
- python: "3.6"
env: TOXENV=py36
- python: "3.7"
- env: TOXENV=py37
+ env: TOXENV=py37,docs
- python: "3.8"
- env: TOXENV=py38,bandit,docs,readme
+ env: TOXENV=py38,bandit,readme
- python: "3.9"
env: TOXENV=py39
- python: "3.10.2"
diff --git a/AUTHORS b/AUTHORS
index bbffe14..c820d6d 100644
--- a/AUTHORS
+++ b/AUTHORS
@@ -30,3 +30,22 @@ Jonathan Huot
Pieter Ennes
Olaf Conradi
Tom Evans
+Bella Woo
+Alan Crosswell
+Nikos Sklikas
+Paul Dekkers
+Jason com4
+Aman Singh Solanki
+uy-rrodriguez
+Sylvain MariƩ
+Hoylen Sue
+Christian Clauss
+Mike Kelly
+Xpyder
+Theron Luhn
+Alexander Freeman1981
+Jon Velando
+Scott Gifford
+Hugo van Kemenade
+Richard Connon
+Karim Kanso
diff --git a/CHANGELOG.rst b/CHANGELOG.rst
index c67f4da..d7882e9 100644
--- a/CHANGELOG.rst
+++ b/CHANGELOG.rst
@@ -1,11 +1,27 @@
Changelog
=========
-3.2.0 (TBD)
+3.2.0 (2022-01-29)
------------------
+OAuth2.0 Client:
+* #795: Add Device Authorization Flow for Web Application
+* #786: Add PKCE support for Client
+* #783: Fallback to none in case of wrong expires_at format.
+
+OAuth2.0 Provider:
+* #790: Add support for CORS to metadata endpoint.
+* #791: Add support for CORS to token endpoint.
+* #787: Remove comma after Bearer in WWW-Authenticate
+
+OAuth2.0 Provider - OIDC:
+ * #755: Call save_token in Hybrid code flow
+ * #751: OIDC add support of refreshing ID Tokens with `refresh_id_token`
+ * #751: The RefreshTokenGrant modifiers now take the same arguments as the
+ AuthorizationCodeGrant modifiers (`token`, `token_handler`, `request`).
-In Progress
-
+General:
+ * Added Python 3.9, 3.10, 3.11
+ * Improve Travis & Coverage
3.1.1 (2021-05-31)
------------------
@@ -13,9 +29,6 @@ OAuth2.0 Provider - Bugfixes
* #753: Fix acceptance of valid IPv6 addresses in URI validation
-OAuth2.0 Provider - Features
- * #751: OIDC add support of refreshing ID Tokens
-
OAuth2.0 Client - Bugfixes
* #730: Base OAuth2 Client now has a consistent way of managing the `scope`: it consistently
@@ -34,8 +47,6 @@ OAuth2.0 Provider - Bugfixes
* #746: OpenID Connect Hybrid - fix nonce not passed to add_id_token
* #756: Different prompt values are now handled according to spec (e.g. prompt=none)
* #759: OpenID Connect - fix Authorization: Basic parsing
- * #751: The RefreshTokenGrant modifiers now take the same arguments as the
- AuthorizationCodeGrant modifiers (`token`, `token_handler`, `request`).
General
* #716: improved skeleton validator for public vs private client
diff --git a/docs/feature_matrix.rst b/docs/feature_matrix.rst
index 56d0cf3..f9309f9 100644
--- a/docs/feature_matrix.rst
+++ b/docs/feature_matrix.rst
@@ -1,8 +1,8 @@
-Supported features and platforms
-================================
+Features and platforms
+======================
-Features
---------
+.. contents::
+ :local:
OAuth 1.0a
..........
@@ -39,16 +39,16 @@ OAuth 2.0 client and provider support for:
- `RFC 6749 section-6`_: Refresh Tokens
- `RFC 6750`_: Bearer Tokens
- `RFC 7009`_: Token Revocation
+- `RFC 7636`_: Proof Key for Code Exchange by OAuth Public Clients (PKCE)
+- `RFC 8628`_: OAuth2.0 Device Authorization Grant
- `RFC Draft`_ Message Authentication Code (MAC) Tokens
+
+Partial implementations (any help/PR are welcomed to complete the list):
+
- OAuth2.0 Provider: `OpenID Connect Core`_
-- OAuth2.0 Provider: `RFC 7636`_: Proof Key for Code Exchange by OAuth Public Clients (PKCE)
- OAuth2.0 Provider: `RFC 7662`_: Token Introspection
- OAuth2.0 Provider: `RFC 8414`_: Authorization Server Metadata
-
-Features to be implemented (any help/PR are welcomed):
-
- OAuth2.0 **Client**: `OpenID Connect Core`_
-- OAuth2.0 **Client**: `RFC 7636`_: Proof Key for Code Exchange by OAuth Public Clients (PKCE)
- OAuth2.0 **Client**: `RFC 7662`_: Token Introspection
- OAuth2.0 **Client**: `RFC 8414`_: Authorization Server Metadata
- SAML2
@@ -59,7 +59,7 @@ Features to be implemented (any help/PR are welcomed):
- ...and more
Platforms
----------
+.........
OAuthLib is mainly developed and tested on 64-bit Linux. It works on
Unix and Unix-like operating systems (including macOS), as well as
@@ -85,5 +85,6 @@ additional packages: see the installation instructions for details.
.. _`RFC 7009`: https://tools.ietf.org/html/rfc7009
.. _`RFC 7662`: https://tools.ietf.org/html/rfc7662
.. _`RFC 7636`: https://tools.ietf.org/html/rfc7636
+.. _`RFC 8628`: https://tools.ietf.org/html/rfc8628
.. _`OpenID Connect Core`: https://openid.net/specs/openid-connect-core-1_0.html
.. _`RFC 8414`: https://tools.ietf.org/html/rfc8414
diff --git a/oauthlib/__init__.py b/oauthlib/__init__.py
index 46c4a92..5dbffc9 100644
--- a/oauthlib/__init__.py
+++ b/oauthlib/__init__.py
@@ -12,7 +12,7 @@ import logging
from logging import NullHandler
__author__ = 'The OAuthlib Community'
-__version__ = '3.2.0-dev'
+__version__ = '3.2.0'
logging.getLogger('oauthlib').addHandler(NullHandler())
diff --git a/oauthlib/oauth2/rfc8628/clients/device.py b/oauthlib/oauth2/rfc8628/clients/device.py
index df7ff68..95c4f5a 100644
--- a/oauthlib/oauth2/rfc8628/clients/device.py
+++ b/oauthlib/oauth2/rfc8628/clients/device.py
@@ -79,7 +79,7 @@ class DeviceClient(Client):
the ``grant_type`` parameter set to
``urn:ietf:params:oauth:grant-type:device_code``::
- >>> from oauthlib.oauth2 import BackendApplicationClient
+ >>> from oauthlib.oauth2 import DeviceClient
>>> client = DeviceClient('your_id', 'your_code')
>>> client.prepare_request_body(scope=['hello', 'world'])
'grant_type=urn:ietf:params:oauth:grant-type:device_code&scope=hello+world'
diff --git a/tox.ini b/tox.ini
index 8e77f3b..c072450 100644
--- a/tox.ini
+++ b/tox.ini
@@ -9,9 +9,9 @@ commands=
# tox -e docs to mimick readthedocs build.
-# as of today, RTD is using python3.6 and doesn't run "setup.py install"
+# as of today, RTD is using python3.7 and doesn't run "setup.py install"
[testenv:docs]
-basepython=python3.6
+basepython=python3.7
skipsdist=True
deps=
sphinx