summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Zíma <vlastimil.zima@nic.cz>2019-10-08 10:56:02 +0200
committerVlastimil Zíma <vlastimil.zima@nic.cz>2019-10-08 10:56:02 +0200
commit4d674262d9542408e4ba7854fe21fd5fb895731b (patch)
treee162bd0d13b06a4039ef4c329e352394ebfc1c55
parent2d741abce6759ee4d0070d22cd57a9cbe22479b8 (diff)
downloadopenid-4d674262d9542408e4ba7854fe21fd5fb895731b.tar.gz
Drop python 3.4
-rw-r--r--.travis.yml1
-rw-r--r--README.md2
-rw-r--r--setup.py3
-rw-r--r--tox.ini2
4 files changed, 3 insertions, 5 deletions
diff --git a/.travis.yml b/.travis.yml
index e8be119..f2f2c46 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -6,7 +6,6 @@ sudo: false
python:
- "2.7"
- - "3.4"
- "3.5"
- "3.6"
- "3.7"
diff --git a/README.md b/README.md
index 9836f49..4a51958 100644
--- a/README.md
+++ b/README.md
@@ -16,7 +16,7 @@ Includes example code and support for a variety of storage back-ends.
## REQUIREMENTS ##
- - Python 2.7, >3.4
+ - Python 2.7, >=3.5
- lxml
- six
- cryptography
diff --git a/setup.py b/setup.py
index f368c49..d0ad769 100644
--- a/setup.py
+++ b/setup.py
@@ -36,7 +36,6 @@ CLASSIFIERS = [
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
@@ -62,7 +61,7 @@ setup(
'openid.extensions',
'openid.extensions.draft',
],
- python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*',
+ python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*',
install_requires=INSTALL_REQUIRES,
extras_require=EXTRAS_REQUIRE,
# license specified by classifier.
diff --git a/tox.ini b/tox.ini
index bbcdc0b..2f54bf0 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,7 @@
[tox]
envlist =
quality
- py{27,34,35,36,37}-{openid,djopenid,httplib2,pycurl,requests}
+ py{27,35,36,37}-{openid,djopenid,httplib2,pycurl,requests}
pypy-{openid,djopenid,httplib2,pycurl,requests}
# tox-travis specials